帮找一下问什么wrong answer

爱圈住你我 2016-05-06 11:52:48

Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.



Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).



Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.



Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


Sample Output
Case 1:
14 1 4

Case 2:
7 1 6



#include<iostream>
#include<stdio.h>
using namespace std;

int a[100010];
int sum;

int main()
{
int n;
//the number of test cases.
cin>>n;
int i;
for(int val=1;val<n+1;val++)
{
cin>>sum;
//the lines starts with a number N
//the N numbers of the line
for(i=0;i<sum;i++)
cin>>a[i];
int ncurstart=0,ncurend=0;
int start=0,end=0;
int ncursum=0;
int ngreatsum = -1001;
for(i=0;i<sum;i++)
{
ncursum+=a[i];
ncurend=i+1;
if(ncursum<0)
{
ncursum=0;
ncurstart=i+1;
ncurend=i+1;
}
if(ncursum>ngreatsum)
{
ngreatsum=ncursum;
start=ncurstart;
end=ncurend;
}

}
printf("Case %d:\n",val);
printf("%d %d %d\n\n",ngreatsum,start+1,end);

}
return 0;
}


...全文
93 3 打赏 收藏 转发到动态 举报
写回复
用AI写文章
3 条回复
切换为时间正序
请发表友善的回复…
发表回复
爱圈住你我 2016-05-06
  • 打赏
  • 举报
回复
详细一些好吗 谢谢你了
爱圈住你我 2016-05-06
  • 打赏
  • 举报
回复
怎么改? 怎么用malloc
赵4老师 2016-05-06
  • 打赏
  • 举报
回复
将a改为用malloc再试试?

64,664

社区成员

发帖
与我相关
我的任务
社区描述
C++ 语言相关问题讨论,技术干货分享,前沿动态等
c++ 技术论坛(原bbs)
社区管理员
  • C++ 语言社区
  • encoderlee
  • paschen
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
  1. 请不要发布与C++技术无关的贴子
  2. 请不要发布与技术无关的招聘、广告的帖子
  3. 请尽可能的描述清楚你的问题,如果涉及到代码请尽可能的格式化一下

试试用AI创作助手写篇文章吧