存储过程中使用 database link

hongqi162 2007-04-02 03:54:18
s:='select aa from table1@aaa';
execute immediate s into Rst;


调用这个存储过程的时候怎么提示


ORA-02041: 客户数据库未开始一个事务处理\nORA-06512



再pl/sql工具中执行是没有问题的
...全文
345 9 打赏 收藏 举报
写回复
9 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
建議樓主到百度www.baidu.com
搜一搜“ORA-02041: 客户数据库未开始一个事务处理\nORA-06512”
有很多類似樓主的問題
  • 打赏
  • 举报
回复
hongqi162 2007-04-02
我使用的是windows2003 server 已经按照roy_88(中国风_燃烧你的激情!!!) 进行配置,但是问题还是没有解决
  • 打赏
  • 举报
回复
中国风 2007-04-02
windows2003装sp1后,会自动启用。xp不行,需要配置
  • 打赏
  • 举报
回复
中国风 2007-04-02
启用分布式事务:
1、运行 regedt32,浏览至 HKEY_LOCAL_MACHINE\Software\Microsoft\MSDTC。
添加一个 DWORD 值 TurnOffRpcSecurity,值数据为 1。
2、重启MS DTC服务。
3、打开“管理工具”的“组件服务”。
a. 浏览至"启动管理工具"。
b. 选择"组件服务"。
c. 展开"组件服务"树,然后展开"我的电脑"。
d. 右键单击"我的电脑",然后选择"属性"。
在 MSDTC 选项卡中,确保选中了下列选项:
网络 DTC 访问
网络管理
网络事务
XA 事务
另外,"DTC 登录帐户"一定要设置为"NT Authority\NetworkService"。
4、重启MS DTC服务。
5、再次运行 regedt32,浏览至 HKEY_LOCAL_MACHINE\Software\Microsoft\MSDTC,然后删除 TurnOffRpcSecurity 项。
  • 打赏
  • 举报
回复
hongqi162 2007-04-02
没有找到你说的配置项目
  • 打赏
  • 举报
回复
子陌红尘 2007-04-02
别处看来的,希望有所帮助:

1. 进入"控制面板"-->"数据源(ODBC)"-->DSN配置画面
把WORKAROUND标签中"DISABLE MICROSOFT TRANSACTION SEN....."选项打勾

2. 重新连接ODBC
  • 打赏
  • 举报
回复
CathySun118 2007-04-02
改成这样不好吗?
s:='select aa from table1@aaa into Rst';
execute immediate s ;
  • 打赏
  • 举报
回复
子陌红尘 2007-04-02
估计要求启动一个分布式的事务。
  • 打赏
  • 举报
回复
hongqi162 2007-04-02
关于oracle的在这里放一下,是不是需要作哪些设置才可以在存储过程中应用啊
  • 打赏
  • 举报
回复
相关推荐
发帖
MS-SQL Server
加入

3.3w+

社区成员

MS-SQL Server相关内容讨论专区
申请成为版主
帖子事件
创建了帖子
2007-04-02 03:54
社区公告
暂无公告