Apache2.0版本在httpd.conf中载入mod_jk.dll,为何总是提示“找不到指定的模块”

hccpro 2002-05-15 03:23:56
!!!!!!!!!
...全文
135 点赞 收藏 12
写回复
12 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
hccpro 2002-08-20
apache2已更新到2.0.40,

apache2.0.40+tomcat4.04也请到如上介绍的地址下载响应的mod_jk.dll

配置通过
回复
bluejacksong 2002-07-08
tomcat4.0.1和apache连接问题:
我在httpd.conf中加了
LoadModule webapp_module modules/mod_webapp.so
WebAppConnection warpConnection warp localhost:8008
但apache还是不能解释我自己写的jsp.
请各位大虾帮忙。
谢谢
回复
hccpro 2002-07-05

有新的进展:


从这里下载mod_jk.dll:

http://www.acg-gmbh.de/mod_jk/

注意下载release版。

使用这个mod_jk.dll可以成功配置于apache2.0.39 + tomcat 4.04

可惜有瑕疵:apache “DirectoryIndex”参数中的index.jsp不起作用


注意,上面的页面不定期更新,会跟随apache和tomcat版本更新而更新,推荐

加入收藏夹。


PS:我还在研究apache官方的mod_jk2.dll,目前没有进展。
回复
hccpro 2002-07-05
俺正在摸索中:

apache 2.0.39 + Tomcat 4.04

使用mod_jk2.dll


现在已经可以找到mod_jk2.dll,但workers.properties文件里面的参数

好像有变动,但没有文档说明,卡在这里无法继续了。
回复
popeast 2002-07-04
我也下载了mod_jk2.dll,是支持apache2的,不过还是beta
奇怪的是我的apache 2.0.36 说版本不支持,可能是apache2太新了
mod_jk2.dll也很久没更新了

另外,最新的apache 2.0.39 win不支持php 4.2.1的php4apache2.dll
无奈,最后还是用回apache
最新的apache 1.3.26不错
回复
hccpro 2002-06-29
确实,我下载了mod_jk2.dll模块,据说是支持apache2的。

可仍旧提示找不到mod_jk2
回复
alexsten 2002-06-28
同意楼上的,apache2的确在和jsp的配合上都有问题。
我也试过ApacheModuleJServ.dll、mod_jk.dll,会出现找不到指定模块的错误,而在apache下没有发现问题。
包括使用apache2+resin 2.12也有问题,虽然resin已经提供了给apache2使用的dll,还是出错了。而apache+resin2.12就没有问题。

现在只好暂时用apache了
回复
popeast 2002-06-28
apache2不支持apache的模块
回复
popeast 2002-06-27
apache2不支持mod_jk.dll
apache2都要新的模块
例如,apache用php4apache.dll,apache2要用php4apache2.dll
不要用apache2,还是apache来得方便些,也成熟些

ps:有mod_jk2.dll,不过问题多多
回复
hccpro 2002-05-15
up
回复
hccpro 2002-05-15
ApacheModuleJServ 已过时了。

Tomcat 用mod_jk.dll替换它了!


另外:用ApacheModuleJServ也提示找不到!
回复
kaitty 2002-05-15
把ApacheModuleJServ.dll文件拷贝到$APACHE_ROOT\modules目录下
然后打开http.conf文件,加入下面的两行:

LoadModule jserv_module modules/ApacheModuleJServ.dll
回复
发动态
发帖子
Web 开发
创建于2007-09-28

7.9w+

社区成员

Java Web 开发
申请成为版主
社区公告
暂无公告