菜鸟问题:EASERVER的字符集和CONNECTION的字符集如何修改的?

fallstone 2007-07-09 02:22:45
我这边PB9,EASERER5.2,连接组件已经连接上了,不过一旦进行数据库操作总是SQLCA。SQLCODE=-1,不管是数据窗口RETRIEVE还是直接SELECT语句(在组件服务器里写的),都是返回-1,我查资料感觉可能是字符集问题,但是我不知道怎么改,特此请教,谢谢各位赐教了!
...全文
211 点赞 收藏 6
写回复
6 条回复
fallstone 2007年07月26日
还要请教一下,发布的时候不在工程所在PBL里的DW包含不进去,把DW移到工程所在的PBL里就可以了.请教怎么处理.
回复 点赞
mkob 2007年07月12日
晕,Copy错地方了。
1、检查数据库所使用的字符集,把EASERER及ORBCodeSet改为跟它一致的看看。
回复 点赞
mkob 2007年07月12日
1、检查数据库所使用的字符集,把RETRIEVE及ORBCodeSet改为跟它一致的看看。
2、尝试检索纯英文的数据试试,从你的描述看,问题似乎不仅仅是字符集的问题。
3、SQLCA.SQLCODE=-1时,把SQLCA.sqlerrtext传回客户端看看是什么错误。
回复 点赞
fallstone 2007年07月09日
补充,用的是PB10+EASERVER5.2
不是PB9,说错了,呵呵。PB9的时候是好的,升级上来就连不上了。一样的程序,除了升级出了点问题修改了一下,其他没有修改。
回复 点赞
fallstone 2007年07月09日
而且把客户端connect的属性加上this.options="ORBCodeSet='iso-1'"后,直接MESSAGEBOX(“”,“测试汉字”),也会出现乱码,显示英文正常。
当然SELECT语句是英文也不能返回成功。
回复 点赞
fallstone 2007年07月09日
自己顶一下,把EASERVER 里 CONNECT CASHES里面的字符集改为iso-1或utf-8,然后把客户端connect的属性加上this.options="ORBCodeSet='iso-1'" 依然是不能操作数据库。ORACLE数据库的字符集是.ZHS16GBK
请高手指教。
回复 点赞
发动态
发帖子
Web 应用
创建于2007-09-28

404

社区成员

2323

社区内容

PowerBuilder Web 应用
社区公告
暂无公告