sos!!pku 1102 各位帮小妹妹看看哪儿出错了。。

p10305119 2007-07-18 01:40:57
各位帮小妹妹看看哪儿出错了。。
就是只能输出一行。。。

原题:
LC-Display
Time Limit:1000MS Memory Limit:10000K
Total Submit:4275 Accepted:1679

Description
A friend of you has just bought a new computer. Until now, the most powerful computer he ever used has been a pocket calculator. Now, looking at his new computer, he is a bit disappointed, because he liked the LC-display of his calculator so much. So you decide to write a program that displays numbers in an LC-display-like style on his computer.

Input
The input contains several lines, one for each number to be displayed. Each line contains two integers s, n (1 <= s <= 10, 0 <= n <= 99 999 999), where n is the number to be displayed and s is the size in which it shall be displayed.

The input file will be terminated by a line containing two zeros. This line should not be processed.

Output
Output the numbers given in the input file in an LC-display-style using s "-" signs for the horizontal segments and s "|" signs for the vertical ones. Each digit occupies exactly s+2 columns and 2s+3 rows. (Be sure to fill all the white space occupied by the digits with blanks, also for the last digit.) There has to be exactly one column of blanks between two digits.

Output a blank line after each number. (You will find a sample of each digit in the sample output.)

Sample Input


2 12345
3 67890
0 0

Sample Output


-- -- --
| | | | | |
| | | | | |
-- -- -- --
| | | | |
| | | | |
-- -- --

--- --- --- --- ---
| | | | | | | |
| | | | | | | |
| | | | | | | |
--- --- ---
| | | | | | | |
| | | | | | | |
| | | | | | | |
--- --- --- ---

我的代码:
#include<iostream.h>
void display1(int n){
cout<<" ";
for(int i=0;i<n;i++)
cout<<"-";
cout<<" ";
}
void display2(int n,int l){
if(l==0){
cout<<"|";
for(int i=0;i<=n;i++)
cout<<" ";
}
if(l==1){
for(int i=0;i<=n;i++)
cout<<" ";
cout<<"|";
}
if(l==2){
cout<<"|";
for(int i=0;i<n;i++)
cout<<" ";
cout<<"|";
}
}
void display(int j,int n){
int m=0;
switch(j){
case 1:
{for(m=0;m<4;m++)
cout<<" ";break;}
case 4:
{for(m=0;m<4;m++)
cout<<" ";break;}
default:
display1(n);
}
}
void display3(int n,int j){
for(int i=0;i<n;i++){
switch(j){
case 2:
display2(n,1);break;
case 3:
display2(n,1);break;
case 7:
display2(n,1);break;
case 1:
display2(n,0);break;
case 5:
display2(n,0);break;
case 6:
display2(n,0);break;
default:display2(n,2);
}
}
}
void main(){
int n;
char a[9];
cin>>n;
cin>>a;
int i=0;
for(int k=0;k<5;k++){
while(a[i]!='\0'){
int j=(int)(a[i]-'0');
i++;
if(k%2==0)
display(j,n);
else
display3(n,j);
}
cout<<endl;
}
}

...全文
159 2 打赏 收藏 转发到动态 举报
写回复
用AI写文章
2 条回复
切换为时间正序
请发表友善的回复…
发表回复
zzyi 2007-07-18
  • 打赏
  • 举报
回复
main函数中,k=1时,i没有重置,直接指向a[i]='\0'的i值,所以while(a[i]!='\0')永远为假。
还有,你在理解这个题时好像有点错误,再好好读读。

建议baidu一下,网上有中文的解释,也有源码,好好参考下。
zzyi 2007-07-18
  • 打赏
  • 举报
回复
main函数中,k=1时,i没有重置,直接指向a[i]='\0'的i值,所以while(a[i]!='\0')永远为假。

c

33,007

社区成员

发帖
与我相关
我的任务
社区描述
数据结构与算法相关内容讨论专区
社区管理员
  • 数据结构与算法社区
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧