这样的问题--关于Applet显示的很简单的问题

thatwind 2001-07-04 07:01:22
为啥俺的Applet在AppletViewer完全正常,可是在IE下却总提示找不到该class文件啊?
先谢了
...全文
48 点赞 收藏 5
写回复
5 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
gnning 2001-07-05
与import无关,否则编译就通不过了。
这里的原因是因为IE的JVM中没有你用到的一些类库,比如说swing的类库。先安装一个Plug-in 1.2或1.3(通常在JRE 1.2或1.3中就包含了)。然后要将调用Applet的HTML文件按照IE的要求改。如果你不知道怎么改,可以使用Sun提供的工具HTML Convertor(在http://java.sun.com/products/plugin/1.2/converter.html 可以下载)来转换。
回复
licher 2001-07-04
我也遇到同时问题:我用jdk1.4Beta版时不行,但换jdk1.2时就解决了!
并且要重新编译!
回复
richard_1 2001-07-04
IE 虚拟机对java的支持有限,只支持到jdk1.1,所以,但用到jdk1.2的类时,IE就找不到了。
回复
gun4rose 2001-07-04
包的路径也要加上。
回复
thatwind 2001-07-04
呵呵,正好有人替我问了。:)
回复
相关推荐
发帖
Java SE
创建于2007-09-28

6.1w+

社区成员

Java 2 Standard Edition
申请成为版主
帖子事件
创建了帖子
2001-07-04 07:01
社区公告
暂无公告