• 全部
  • 语言基础/算法/系统设计
  • 数据库相关
  • 图形处理/多媒体
  • 网络通信/分布式开发
  • VCL组件开发及应用
  • Windows SDK/API
  • 问答

程序打包后,安装到其他客户机都可连接上数据库,唯独一台笔记本连不上???

booksfount 2002-12-18 01:32:21
程序打包后,安装到其他客户机都可连接上数据库,唯独一台笔记本连不上???这个笔记本的操作系统是xp的,曾经第一次安装的时候,可以连上,后来修改程序了,重新打了包,就把电脑上曾经安装的卸掉,然后重新安装(没有修改连接数据库那段程序),接着,数据库就怎么也连接不上了,而其他机器都好好的(操作系统win2000)可以连接上。我设置了笔记本电脑中的odbc,可以连接上服务器,测试连接成功,可程序中为何不行。

开发环境delphi 6,sql server2000,后来我又下载了一个MDAC2.7安装了也不行



还有一个问题,我用了第三方控件1stclass中的fcTreecombo,打包后,其他机器根本无法使用这个控件,打包时,我已经把bpl 拷贝到安装路径下,可还是不行。我应该注意什么地方呢???哪里出了问题?????


谢谢帮助!
...全文
30 点赞 收藏 14
写回复
14 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
booksfount 2002-12-18
谢谢大家!我准备结贴了!看来只好放弃那台电脑了!
回复
booksfount 2002-12-18
曾经在那个笔记本上安装成功一次,修改程序,从那以后,就再也连接不上了?????????????
回复
booksfount 2002-12-18

不好意思:第二个问题是少copy了一个dcu文件,谢谢大家
第一个问题还是没有解决?
出来'找不到指定的模块'是不是因为有什么冲突呢???
回复
bigysw 2002-12-18
整复杂了,网络问题,或者是ADO版本与XP的兼容问题,搞不定了!
回复
booksfount 2002-12-18
去掉except直接true,
用ADOConnectionPactInfoMessage中写
showMessage(error.Description);的

出来的提示是:'找不到指定的模块'
showmessage注释,出来的提示还是'找不到指定的模块'????请问,什么原因????
回复
booksfount 2002-12-18
谢谢各位:我再试验一下!
回复
lws0472 2002-12-18
如果你是用ADO连接的数据库,xp下直接用就可以了。
你用odbc能连上数据库,说明你的网络是好的。具体情况具体分析吧,无能为力,实在不行重装系统吧.
回复
bigysw 2002-12-18
如果不是activeX或者dll,是不需要 .bpl 也不许要 .dcu 的,跟你第三方控件怎么打包无关。

————————————————————————————————————————
try
dmpact.ADOConnectionPact.Connected:=True;
except
showmessage('参数配置错误,数据库连接失败!');
freeandnil(myinifile);
exit;
end;

——————————————————————————————————————————
这段代码的try except 去掉,直接connected:=true;
编译,拷贝到笔记本上覆盖原来的应用程序,再试试看,就肯定有错误的英文提示了,再贴出来看看。
回复
lws0472 2002-12-18
Groups and Files是打包工具中的,如setupbuilder,installshield都有,不是delphi的,你说的那个帖子,看他的意思,他是让你打包在system下,就不用设置路径了。
只要用到的文件和exe在一个目录下就没有问题,没必要放在system下。
从你上面的意思看,可能你还是只是拷了bpl,没有拷bpl对应控件的dcu,也就是控件fcTreecombo的dcu文件
回复
booksfount 2002-12-18
to lws0472(编程工人)
错误提示是我用
try
dmpact.ADOConnectionPact.Connected:=True;
except
showmessage('参数配置错误,数据库连接失败!');
freeandnil(myinifile);
exit;
end;

然后出现参数配置错误,数据库连接失败!
我在datamodule的
ADOConnectionPactInfoMessage中写
showMessage(error.Description);

连接不上,根本没有英文提示,只有我在程序中写的中文提示??????
回复
booksfount 2002-12-18
第一个问题:我是在一个局域网系统内,协议安装了tcp/ip ,netbios也安装了,还有哪个问题呢???这台笔记本可以访问到服务器,网线连接好好的,通过系统的odbc设置没问题呀???

第二个问题:dcu文件我已经打到包里了。是不是还有什么地方需要设置(不是activex)
project options->packages->runtime packages下面的check框已经去掉打勾了。
还是不行

我的bpl放到安装目录或是系统目录都试验不行。
我查询贴子,找到一个网友这样说打包第三方控件的
---------------
把你的控件包 *.bpl在Groups and Files对话框中用Insert Files命令加入System Files
(和VCL50.bpl在一起)
--------------------
可是我没有找到Groups and Files???在哪里
回复
lws0472 2002-12-18
1.连接不上没有提示什么错误吗?
2。拷bpl的同时还要拷bpl下控件的dcu文件。
回复
NightCloud 2002-12-18
第二个问题,你还需要拷一个.duc文件吧
回复
bigysw 2002-12-18
是网络系统吗?第一个问题可能是在网络设置上。

第二个问题:那个控件是不是ACTIVEX的?如果是,则需要注册,如果不是,可能你在编译系统的时候,把 project options->packages->runtime packages下面的check框去掉打勾。
回复
发帖
Delphi
创建于2007-08-02

4873

社区成员

Delphi 开发及应用
申请成为版主
帖子事件
创建了帖子
2002-12-18 01:32
社区公告
暂无公告