关于控件的发布

monkst 2003-01-21 10:36:17
我开了一个工程做了一个控件,然后把它加到另一个工程中去,测试完毕编译后,进行打包(package & deployment wizard),在本机上安装没有任何问题,可到了另一台干净的机器,安装好后运行,发生了控件版本过期的的问题,请问如何解决。
...全文
4 点赞 收藏 2
写回复
2 条回复
切换为时间正序
请发表友善的回复…
发表回复
monkst 2003-01-22
谢谢,改为2进制兼容方式就好了。只是为什么?
回复
holydiablo 2003-01-21
这里有一些问题要先明确
1、OCX的编译最好是2进制兼容方式
2、OCX里最好不要再使用其他的OCX(标准控件除外)
3、控件依赖的DLL要都齐全

你可以先通过手工方式去另一台机器注册看看是不是可以,这和安装程序关系一般不大,不过VB自带的那个工具最好早点扔掉,这玩意后患无穷。
回复
发动态
发帖子
VB基础类
创建于2007-09-28

7453

社区成员

VB 基础类
申请成为版主
社区公告
暂无公告