jdk1.3.1里面没有javax.sql.*?

wood23 2003-03-25 09:25:55
DataSourceJNDI.java:2: package javax.sql does not exist
import javax.sql.*;
^
DataSourceJNDI.java:3: package oracle.jdbc.driver does not exist
import oracle.jdbc.driver.*;
^

我装的Oracle9i(920),用它自带的jdk(1.3.1)。
...全文
17 点赞 收藏 6
写回复
6 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
wood23 2003-03-25
谢谢各位大力帮助。
诚如scriptskychen所言,在下正是用JDBC连接,看了一篇教程,因说JNDI连接数据比较好,刚试。
我还想问一下oracle.jdbc.driver这个也不存在是因为什么呢?应该是Oracle的问题了吧!?另我没装9iAS。
回复
scriptskychen 2003-03-25
不是javax.sql 的问题
是你用来连接数据库是用jdbc
如果你用odbc:jdbc就会没有这个问题
如果你还要用jdbc可以去下载一个,oracle的jdbc连接类!
http://www.cn-java.com
到这里看看吧!!
回复
kofwr 2003-03-25
对,这个还是去sun下载的好..
回复
sgdb 2003-03-25
到sun 的网站下
回复
wood23 2003-03-25
请问偶如何得到它?(j2ee.jar..)
回复
kofwr 2003-03-25
1.3里是没有的,不过其他包里有,比如j2ee.jar..
回复
相关推荐
发帖
Web 开发
创建于2007-09-28

8.0w+

社区成员

Java Web 开发
申请成为版主
帖子事件
创建了帖子
2003-03-25 09:25
社区公告
暂无公告