求不用pragma warnning disable 4786,在vc工里设置忽略warn4786的方法,只单独忽略4786,我以前用过,现在忘了

lxrlxr20021 2008-04-10 01:51:56
求不用pragma warnning disable 4786,在vc工里设置忽略warn4786的方法,只单独忽略4786,我以前用过,现在忘了
...全文
163 点赞 收藏 10
写回复
10 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
lxrlxr20021 2008-04-10
thrand you
可能我记错了我原先是在2005下的,vc6只能一个个加了
回复
VC6我只找到
/w disable all warnings
/W<n> set warning level (default n=1)
/WX treat warnings as errors
这三个警告的选项
没有对指定错误的
回复
skyful123 2008-04-10
看来我回复的慢了点
回复
英文说明
http://msdn2.microsoft.com/en-us/library/thxezb7y(VS.80).aspx
中文说明
http://msdn2.microsoft.com/zh-cn/library/thxezb7y(VS.80).aspx
回复
skyful123 2008-04-10
楼上说的 是在 2003里面 不是VC6
回复
Open the project's Property Pages dialog box. For details, see How to: Open Project Property Pages.

Click the C/C++ folder.

Click the General property page and modify the Warning Level or Treat Warnings as Errors properties.

Click the Advanced property page and modify the Disable Specific Warnings property.

For the remaining options, click the Command Line property page and type the compiler option in the Additional Options box.

回复
对应的编译选项是wd,你看看那个选项对应的是这个编译选项.或者自己添加上去.

/wd n
禁用指定的编译器警告,其中 n 是编译器警告编号。
例如,/wd4326 禁用编译器警告 C4326。
回复
有一个选项就是 "禁用特定的警告",你在里面输入警告的号码即可
回复
lxrlxr20021 2008-04-10
akirya
我没有找到工程->属性->C++->高级,我要的不是warnning level,能不能详细一点。
回复
工程->属性->C++->高级->禁用特定的警告
回复
相关推荐
发帖
VC/MFC
创建于2007-09-28

1.5w+

社区成员

VC/MFC相关问题讨论
申请成为版主
帖子事件
创建了帖子
2008-04-10 01:51
社区公告

        VC/MFC社区版块或许是CSDN最“古老”的版块了,记忆之中,与CSDN的年龄几乎差不多。随着时间的推移,MFC技术渐渐的偏离了开发主流,若干年之后的今天,当我们面对着微软的这个经典之笔,内心充满着敬意,那些曾经的记忆,可以说代表着二十年前曾经的辉煌……
        向经典致敬,或许是老一代程序员内心里面难以释怀的感受。互联网大行其道的今天,我们期待着MFC技术能够恢复其曾经的辉煌,或许这个期待会永远成为一种“梦想”,或许一切皆有可能……
        我们希望这个版块可以很好的适配Web时代,期待更好的互联网技术能够使得MFC技术框架得以重现活力,……