请问:怎么把在访问tomcat中的(http://localhost:8080)主页时把断口8080去掉,令为怎么设置为127.0.0.1等IP访问??谢谢!

feigmin 2001-10-07 05:32:44
...全文
154 点赞 收藏 7
写回复
7 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
laocao 2001-10-09
uninstall iis or some other server
回复
yun15291li 2001-10-09
你的80端口被站用了吧我的改成520就可了。随便改一个别的吧。
回复
lci21 2001-10-09
初步推断:你的80端口已经被别的服务占用了,如果你启动的有iis、或pws之类的服务占用了80端口,先关闭这些服务,在启动tomcat
回复
feigmin 2001-10-09
多谢lci21(流浪少年),我搞定了!!
我失败是因为我没把IIs关闭!呵呵
回复
cherami 2001-10-08
如果你将tomcat和apche等专用web服务器结合使用就不用设置了,因为这些服务器缺省的端口就是80,如果是独立使用tomcat就要像上面的仁兄说的修改tomcat目录下的conf\servr.xml了。
回复
feigmin 2001-10-08
兄弟不行阿。我把下面这段代码中的8080改为80后,当启动tomcat是本应该弹出一个命令提示窗口的,但该后却不出现,而且启动后也不能访问。我在没问这个问题前也试过这样设置,当时也失败了。这是怎么回事??
<Connector className="org.apache.tomcat.service.SimpleTcpConnector">
<Parameter name="handler" value="org.apache.tomcat.service.http.HttpConnectionHandler"/>
<Parameter name="port" value="8080"/>
</Connector>
回复
dolphin1476 2001-10-07
改server.xml, 把port 8080改成port 80
一定要给分了,下次我还还回答
回复
相关推荐
发帖
Web 开发
创建于2007-09-28

8.0w+

社区成员

Java Web 开发
申请成为版主
帖子事件
创建了帖子
2001-10-07 05:32
社区公告
暂无公告