php4-mysql4现在过时了吗?

cnljc 2008-11-29 01:57:39
最近学php,在xp环境下用EasyAPM-Server做的php环境
EasyAPM-Server 06年就不出了,只是当时我用过,感觉很好

版本:2.0.2 [2005-08-01]
EasyAPM-Server 是 Win32(2000/XP/2003) 系统下的 Apache+PHP+MySQL 运行环境快速集成安装套件,帮助您快速建立测试及运行环境

程序:
  Apache v2.0.54 (Win32)
  PHP v4.4.0 (Win32)
  Zend Optimizer v2.5.10a (Win32)
  MySQL v4.0.25 (Win32)
  phpMyAdmin v2.6.3-pl1

这样的配置是不是已经落后了,不再适合现在的大部分程序?下了一个小程序(php5),数据都无法导入
...全文
93 点赞 收藏 9
写回复
9 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
dzxccsu 2008-11-29
[Quote=引用 3 楼 wzwen 的回复:]
我现在用的就是php5
不知php4和php5有哪些区别?
[/Quote]最大区别就是php5引入了面向对象!
回复
wzwen 2008-11-29
我现在用的就是php5
不知php4和php5有哪些区别?
回复
peacock 2008-11-29
没过时,事实上很多程序都还在用php4以及mysql4,不过还是推荐使用php5
回复
清风闲客 2008-11-29
有点老了

建议:
apache_2.0.43
php-5.1.1
mysql-5.0.11
phpmyadmin
回复
Zijian_Zhang 2008-11-29
PHP5就是对面向对象的东西加强了
回复
Zijian_Zhang 2008-11-29
比我的还好!告诉你吧,许多虚拟主机的配置都是PHP4、MYSQL4的,中国万网的就是这样,PHP4.3.11、MYSQL4的
回复
qap22 2008-11-29
不懂,up
回复
wangyiting1 2008-11-29
对了,PHP5引入了面向对象。我现在正在学呢。
其他区别不大的。
回复
codejian 2008-11-29
不错,推荐PHP5,MYSQL5以上版本,兼容以前的,适应现在更多需要!
回复
相关推荐
发帖
基础编程
创建于2007-09-28

2.1w+

社区成员

从PHP安装配置,PHP入门,PHP基础到PHP应用
申请成为版主
帖子事件
创建了帖子
2008-11-29 01:57
社区公告
暂无公告