unix 执行脚本

fzm2008 2008-12-03 04:30:34
20 14 * * * (sh /apps/fzm/comm.sh >>/apps/fzm/comm.log)

comm.sh
#!/bin/sh
./fzm.sh


fzm.sh
#!/bin/sh
echo "####################"

手动执行 comm.sh 没有问题 一切正常 sh comm.sh

为什么在cron里面就不行呢!!!
...全文
194 点赞 收藏 9
写回复
9 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
jingruiking 2009-03-03
把 echo "####################"
这行去掉
回复
up
回复
fzzlz 2009-03-02
对 X权限要给才行
回复
banmiton 2009-01-15
脚本是否忘记加上可执行权限?chmod +x *.sh ,如果已加上,则看执行路径是否正确?echo $PATH看路径是否包含当前执行路径,没有可以添加。。。。
回复
cuijie_cn 2009-01-12
1、路径设置为绝对路径
2、crontab设置是不是有问题 crontab -l检查看看。
回复
genghb 2009-01-06
因为你手工执行的路径与crontab 启动的路径不一致,
另外如果使用了环境变量的,在脚本中也需要加载才能正常执行
回复
Dawson_Wang 2009-01-06
楼上的说的很对。看你的CRONTAB最后一项里好像不是绝对路径。
回复
applewood 2008-12-04
写cron 脚本的两个经验:

1。 脚本里要用绝对路径
2。 最好是明确设定PATH 及其它的环境变量
回复
fzm2008 2008-12-03
20 14 * * * (sh /apps/fzm/comm.sh >>/apps/fzm/comm.log)

comm.sh
#!/bin/sh
./fzm.sh


fzm.sh
#!/bin/sh
echo "####################"
sqlplus user/pass/sid <<!
set serveroutput on ;
set timing on ;
alter session enable parallel dml;
alter session set db_file_multiblock_read_count=32;
exec $1;
exit
!

手动执行 comm.sh 没有问题 一切正常 sh comm.sh

为什么在cron里面就不行呢!!!

mail里提示
*************************************************
Cron: 前面的信息是标准输出
和您的一个 crontab 命令的标准错误:

我应该如何解决这个问题????谢谢
回复
相关推荐
发帖
UNIX文化
创建于2007-08-27

2155

社区成员

Linux/Unix社区 UNIX文化
申请成为版主
帖子事件
创建了帖子
2008-12-03 04:30
社区公告
暂无公告