请教是sybase哪个jdbc支持setAutoCommit(false);一直关注,解决就揭贴

www203 上海万象文化配送有限公司 信息技术部总监  2003-03-30 07:55:04
我为了事物回滚
设置为:setAutoCommit(false);
但是运行一直报错
好象提示是jdbc不支持
仔细阅读jdbc

请问是不是有那个特定的版本支持jdbc?
...全文
45 点赞 收藏 11
写回复
11 条回复
切换为时间正序
请发表友善的回复…
发表回复
ww203 2003-04-11
有一个sql_server.sql需要执行。
回复
www203 2003-04-01
sybase
回复
www203 2003-03-31
没有解决
up一下
回复
www203 2003-03-31
没有解决
up一下
回复
wdman 2003-03-31
你使用的是什么数据库?
回复
www203 2003-03-31
报错信息是:java.sql.SQLException: JZ0SJ: 没有在此数据库中发现元数据存取器信息。 请按 jConnect 文档中所述安装 所需的表。

什么意思是?
没有碰到过
进行jdbc操作需要什么特定的表吗?
回复
www203 2003-03-31
java.sql.SQLException: JZ0SJ: 没有在此数据库中发现元数据存取器信息。 请按 jConnect 文档中所述安装 所需的表。

at com.sybase.jdbc2.jdbc.ErrorMessage.raiseError(ErrorMessage.java:500)

at com.sybase.jdbc2.jdbc.MdaManager.loadMetaData(MdaManager.java:458)

at com.sybase.jdbc2.jdbc.MdaManager.<init>(MdaManager.java:145)

at com.sybase.jdbc2.jdbc.MdaManager.<init>(MdaManager.java:130)

at com.sybase.jdbc2.jdbc.SybConnection.checkMDA(SybConnection.java:1779)

at com.sybase.jdbc2.jdbc.SybConnection.getMDA(SybConnection.java:1560)

at com.sybase.jdbc2.tds.Tds.setOption(Tds.java:1079)

at com.sybase.jdbc2.jdbc.SybConnection.setAutoCommit(SybConnection.java:634)

at com.wfsw.sybase.main(sybase.java:27)
回复
IT老兵 2003-03-31
you need jdbc 2.0 or above
回复
orac203 2003-03-31
帮你up
回复
www203 2003-03-30
但是我现在用的是:jconnect55
他不支持
jconnect5。2会支持吗?
期待您的回答
回复
hanps 2003-03-30
jconnect5.2
回复
发动态
发帖子
Sybase
创建于2007-09-28

2573

社区成员

Sybase相关技术讨论区
申请成为版主
社区公告
暂无公告