myeclipse中安装JavaFX插件的问题

RickyLoveCoding 2009-04-11 07:07:01
本人用的Myeclipse7.0,安装了javafx_sdk-1_1_1-windows-i586.exe及com.sun.javafx.eclipse.feature-win32-win32-x86-1.0.1.zip这个插件。
在eclipse中新建JAVA项目后new了一个javaFX 的Sample,结果边上一排红叉
报错为:
Invalid assignment (10个)
软件包javafx.scene不存在
软件包javafx.scene.text不存在
软件包javafx.scene.text不存在
软件包javafx.stage不存在
无法访问java.lang.Builtins未找到javafx.lang.Builtins的类文件
找不到符号 符号:类Font位置:...........
找不到符号 符号:类Scene位置:...........
找不到符号 符号:类Stage位置:...........
找不到符号 符号:类Text位置:...........

项目文件夹中有JavaFX System Library

请问如何解决此问题?(在netbeans6.5中使用javaFX插件可正常编译运行)




//自动生成的代码如下
package xxxxxxxxxx;

import javafx.stage.Stage;
import javafx.scene.Scene;
import javafx.scene.text.Text;
import javafx.scene.text.Font;

Stage {
title: "Application title"
width: 250
height: 80
scene: Scene {
content: Text {
font : Font {
size : 24
}
x: 10, y: 30
content: "Application content"
}
}
}
//
...全文
1195 6 打赏 收藏 举报
写回复
6 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
wwwtyb 2010-09-14
我也出现了你相同的问题,我在myeclipse8.5中安装了javaFx插件,然后新建*.fx文件,里面导入java的类不发生错误,只要import javafx.*.* 就提示 undefined type javafx.*.*,有红叉。还望哪位高人赐教啊。
但是在netbeans6.9.1中可以。我的是javafx1.3.1+java1.6.u21,
  • 打赏
  • 举报
回复
RickyLoveCoding 2009-04-13
解决了,原来JDK的路径设错了,汗,,我设到Lib去了。
所有包成功导入了,但又出来个问题,说Int型不兼容,缺了个包
Google了一下发现fx最新的1.1.1版本有个BUG
如下:
--------------------------------------------------------------------------------
Note: As of SDK 1.1, the language also contains numeric types that align with those found in the Java programming language. The full list of numeric types is therefore: Byte, Short, Number, Integer, Long, Float, Double, and Character. However, the advice given above still holds true: most programmers will only need Integer (or Number) for the scripts that they write. If you are coming to this language from a Java programming language background and have a task that absolutely requires one of the other types, just know that these additional types are now available to your scripts.

好吧,我装1.0.1吧
  • 打赏
  • 举报
回复
great1681 2009-04-12
我也是使用的myeclipse7.0,感觉7.0和之前的版本在安装插件
上有很大的不同(指的是非在线安装),楼主的问题应该是这个插件没有装好~~
具体安装方法请楼主参见:
http://blog.csdn.net/great1681/archive/2009/04/09/4059442.aspx
  • 打赏
  • 举报
回复
cangzhubai 2009-04-12
学习
  • 打赏
  • 举报
回复
ET郭强 2009-04-12
up
  • 打赏
  • 举报
回复
Defonds 2009-04-11
我的资源里有本myeclipse教程,介绍的很详细,配有大量图片、源码说明
既可以用来做学习的教程书,又可以用来做工作的参考书
有需要的朋友可以去看看
  • 打赏
  • 举报
回复
发帖
Eclipse

5.8w+

社区成员

Java Eclipse
社区管理员
  • Eclipse
加入社区
帖子事件
创建了帖子
2009-04-11 07:07
社区公告
暂无公告