急阿,100分!关于在98下读取access2000的问题!

xinjiekou 2003-04-01 01:42:31
我的vb程序用的数据库是access2000,在2000、xp下安装后运行没问题,可是一到98下安装后运行读数据库的数据就不对了,是不是access2000和98不兼容阿?请大家帮忙阿!!!!
...全文
48 点赞 收藏 11
写回复
11 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
samuelliushan 2003-04-07
这种问题我也有遇到,上面的兄弟说的没错。
回复
_131_ 2003-04-07
解决了就结帐!
不是偶很看重专家分,既然大家付出了劳动,就应该有回报!!!
回复
xinjiekou 2003-04-02
已解决了,谢谢各位了
安装mdac2。7就可以了,安装office2000好像不行呵
回复
饮水需思源 2003-04-01
将你代码中的jet3.51全部改成jet4.0
回复
ganzhiruogy 2003-04-01
还要修改连接数据库的引擎:Microsoft.Jet.OLEDB.3.51 改为Microsoft.Jet.OLEDB.4.0
conMainMdb.ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;Data Source= " & App.Path & "\MainMDB.mdb;Persist Security Info=False"
回复
zuing 2003-04-01
我正为这个事情苦恼,确定为Access的驱动问题!但是我安装了mdac_type 2.7还是不行!我也不能安装office 2000.还有什么方法可以从3.51升级到4.0啊?(安装office 2000肯定能够解决问题)
回复
heipifeng 2003-04-01
去下载sp5补丁。里面有mdac
回复
lypgo 2003-04-01
是呀,我也遇到了,你去微软件网站载MDAC 2.5就可以解决了。
回复
noahman 2003-04-01
我以前也有如此的经历,确为版本问题,_131_(\*咕咚*/) 兄的建议有理,值得参考
回复
holydiablo 2003-04-01
access2000 dao3.6、ado2.6以后都可以支持
回复
_131_ 2003-04-01
access2000用ado2.7以后的版本打开不会出错!
在2000,xp下运行没有问题,估计是这两个操作系统的ado就是2.7的!
你在98上运行一下mdac_type 2.7!
或者在98上安装一个office2000
回复
相关推荐
发帖

1187

社区成员

VB 数据库(包含打印,安装,报表)
申请成为版主
帖子事件
创建了帖子
2003-04-01 01:42
社区公告
暂无公告