使用化境无组件上传程序时碰到以下问题:

storein 2003-07-30 12:13:41
使用化境无组件上传程序时碰到以下问题:


服务器对象 错误 'ASP 0177 : 800401f3'

Server.CreateObject 失败

/upload_5xsoft.inc, 行36

800401f3 化境HTTP上传程序 Version 2.0



Microsoft VBScript 运行时错误 错误 '800a01a8'

缺少对象: 'Data_5xsoft'

/upload_5xsoft.inc, 行117
请输入要上传至的目录! [返回]

我使用的就是化境自带的例子.ADO版本是2.6,
使用环境是WIN98+PWS
虚拟目录是
C:\Inetpub\wwwroot
无组件上传文件就放在wwwroot目录下

大家帮我看看这是怎么会事
谢谢!
...全文
85 点赞 收藏 10
写回复
10 条回复
切换为时间正序
请发表友善的回复…
发表回复
coffee_cn 2003-07-30
sh.ce.net.cn/web8/tools/up.zip
回复
zhangking 2003-07-30
'Data_5xsoft' --- 可能要注册什么组件.
回复
storein 2003-07-30
这个我肯定是有的.因为我下载的是全部的例子程序,当然也包括这个文件
问题是它运行到 这个文件的第36行出错.也就是:
set tStream = Server.CreateObject("adodb.stream")
这里的时候,报告创建失败的.
我是这样使用例子的:
在C:\Inetpub\wwwroot下建立子目录111,然后运行例子时 在"上传到"那里填入111,或者../111 或者 ./111 都不对.我填入 C:\Temp 也不对(Temp目录存在),都是以上的问题
不知道是怎么回事了.
回复
roymans 2003-07-30
你需要upload_5xsoft.inc文件
回复
storein 2003-07-30
多谢各位,问题已经解决
解决方法是重新安装了PWS,并且重新安装了微软的MDAC2.6
然后就没有问题了,能正常上传数据.
看来以前要么是PWS的问题,要么是ADO的问题.
谢谢各位,请收分.
回复
topmonkey 2003-07-30
装MDAC2.5以上试试看。
回复
杨小杨 2003-07-30
装WIN2000,用IIS吧!

我在2000+IIS5.0没有问题!

PWS没用过!
回复
storein 2003-07-30
cdsun() :
我有这个文件的,在上面的错误提示中Server.CreateObject 失败
/upload_5xsoft.inc, 行36 这里就是这个文件的第36行有语句 set tStream = Server.CreateObject("adodb.stream") ,执行到这里错的.没有办法创建 adodb.stream

coffee_cn(coffee) :

我已经下载了你提供的程序,但是还是同样的问题,我怀疑是不是我的PWS有问题?因为我发现我想停止PWS,都提示有错误,需要等段时间,然后才能停止,并重新启动PWS.在原来安装PWS的时候就提示有一个小问题 什么 metabase 错误.不过其他的操作数据库方面是能够正常进行的.
回复
cdsun 2003-07-30
你需要upload_5xsoft.inc文件
不需要注册组件
回复
storein 2003-07-30
当然是不需要注册组件的.因为这是无组件上传程序的哦
这是这里很多人都在用的无组件上传程序,是稻香老农写的
回复
发动态
发帖子
ASP
创建于2007-09-28

2.8w+

社区成员

ASP即Active Server Pages,是Microsoft公司开发的服务器端脚本环境。
申请成为版主
社区公告
暂无公告