windows mysql提示:1045 access denied for user 'root'@'localhost' using password yes

alice_2860 2009-05-15 09:22:18
加精
windowsxp系统 mysql-5.0.11-beta-win32
提示:1045 access denied for user 'root'@'localhost' using password yes
前几天都好好的,昨天没弄,结果今天晚上过来提示上面的这个错误,重启mysql还是不可以
网上的方法看了几个但是不知道怎么弄
方法一:
# /etc/init.d/mysql stop
# mysqld_safe --user=mysql --skip-grant-tables --skip-networking &
# mysql -u root mysql
mysql> UPDATE user SET Password=PASSWORD(’newpassword’) where USER=’root’;
mysql> FLUSH PRIVILEGES;
mysql> quit
# /etc/init.d/mysql restart
# mysql -uroot -p
Enter password: <输入新设的密码newpassword>
mysql>
方法二:
直接使用/etc/mysql/debian.cnf文件中[client]节提供的用户名和密码:
# mysql -udebian-sys-maint -p
Enter password: <输入[client]节的密码>
mysql> UPDATE user SET Password=PASSWORD(’newpassword’) where USER=’root’;
mysql> FLUSH PRIVILEGES;
mysql> quit
# mysql -uroot -p
Enter password: <输入新设的密码newpassword>
mysql>

内容来自: 脚本之家 www.jb51.net

另一个方法
Windows:

1. 管理员登陆系统,停止mysql服务或者结束mysqld-nt进程
2. 进入命令行,来到mysql的安装目录.假设安装目录为 d:\mysql\ , CMD进入命令行
3. 运行 d:\mysql\bin\mysqld-nt --skip-grant-tables 启动mysql,关闭权限的检查
4. 运行 d:\mysql\bin\mysqladmin -u root flush-privileges password "newpassword" 重设root密码
5. 重新启动mysql服务

第4步也可以直接修改mysql表,所用到的SQL语句同linux部分,这里就不再重复了.

请不要乱给答案否则不给分
一定要试验过的成功经验,谢谢!
...全文
392257 99 打赏 收藏 举报
写回复
99 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
damin7605157 2012-09-29
[Quote=引用 3 楼 的回复:]
那是在LINUX下的命令,换成WINDOWS下的就可以了。

到WINDOWS的命令行了(‘DOS’ 下),切换到你的MySQL bin目录下。 比如我的是 C:\Program Files\MySQL\MySQL Server 5.1\bin
然后敲下面的粗体的命令。注意你的my.ini位置。

C:\Program Files\MySQL\MySQL Server 5.1\bin>m……
[/Quote]

对三楼表示由衷的感谢。
  • 打赏
  • 举报
回复
odaynot 2012-07-19
谢谢3楼的ACMAIN_CHM,问题已经解决[Quote=引用 3 楼 的回复:]
那是在LINUX下的命令,换成WINDOWS下的就可以了。

到WINDOWS的命令行了(‘DOS’ 下),切换到你的MySQL bin目录下。 比如我的是 C:\Program Files\MySQL\MySQL Server 5.1\bin
然后敲下面的粗体的命令。注意你的my.ini位置。

C:\Program Files\MySQL\MySQL Server 5.1\bin>m……
[/Quote]
  • 打赏
  • 举报
回复
lirongzhou 2012-07-08
非常感谢3楼
  • 打赏
  • 举报
回复
q631951221 2012-06-26
谢谢楼主哈!
  • 打赏
  • 举报
回复
q631951221 2012-06-26
用第一种方法解决了,但还不知道时什么原因
  • 打赏
  • 举报
回复
eros1102624299 2012-06-21
eclipse里面运行后出现的这个是怎么的呢?数据库连接没问题啊
  • 打赏
  • 举报
回复
廖俊才 2012-06-05
[Quote=引用 86 楼 的回复:]

工昨天安装的一个mysql昨天 是可以正常使用的,可是等到我今天早上来打开数据库的时候就是提示了
1045 - access deied for user:'root@localhost'(using password:yes)
这样的错误提示信息,当我看到这个贴的时候我就是开启了那个mysql51那个服务就可以了,
因为他是任务管理器里面有两服务的,一个是mysql服务另一个就是mysq……
[/Quote]

只有一个mysql啊,哪里有mysql51
  • 打赏
  • 举报
回复
廖俊才 2012-06-05
第一种:结果是:ERROR 1046 (3D000): No database selected
  • 打赏
  • 举报
回复
丛林鼠小弟 2012-04-16
三楼 正解
  • 打赏
  • 举报
回复
pc2061 2012-02-24
我按照三楼的方法搞定了 谢谢
  • 打赏
  • 举报
回复
搬砖生涯 2011-12-20
第三个试过了 过了
  • 打赏
  • 举报
回复
lerroy 2011-12-10
[Quote=引用 86 楼 zhou946163 的回复:]

工昨天安装的一个mysql昨天 是可以正常使用的,可是等到我今天早上来打开数据库的时候就是提示了
1045 - access deied for user:'root@localhost'(using password:yes)
这样的错误提示信息,当我看到这个贴的时候我就是开启了那个mysql51那个服务就可以了,
因为他是任务管理器里面有两服务的,一个是mysql服务另一个就是mysq……
[/Quote] 楼上正解啊!刚好解决了!谢谢额
  • 打赏
  • 举报
回复
shania02 2011-11-29
3楼正解,多谢您了,呵呵!我是win7,安的wamp包,新手,和我一样的问题可以试试。
  • 打赏
  • 举报
回复
zhou946163 2011-11-26
工昨天安装的一个mysql昨天 是可以正常使用的,可是等到我今天早上来打开数据库的时候就是提示了
1045 - access deied for user:'root@localhost'(using password:yes)
这样的错误提示信息,当我看到这个贴的时候我就是开启了那个mysql51那个服务就可以了,
因为他是任务管理器里面有两服务的,一个是mysql服务另一个就是mysql51了,然而我安装的时候选择
的就是mysql51了,而系统启动的时候就是默认开启了,第一个服务的即mysql,结果我就,结束mysql
服务而开启第二个服务mysql51就没有问题了,正常打开了。
  • 打赏
  • 举报
回复
fkl0707 2011-11-01
我想问一下这个问题的根本原因是什么呢?
  • 打赏
  • 举报
回复
lkssbc 2011-08-18
命令提示符 net stop mysql 停止mysql服务
C:\Documents and Settings\tony>net stop mysql
MySQL 服务正在停止.
MySQL 服务已成功停止。

进入bin目录
C:\Documents and Settings\tony>cd C:\Program Files\MySQL\MySQL Server 5.0\bin
C:\Program Files\MySQL\MySQL Server 5.0\bin>mysqld-nt --skip-grant-tables


重新打开一个命令提示符窗口
进入bin目录
C:\Program Files\MySQL\MySQL Server 5.0\bin>mysql
mysql> use mysql;



这样,查看user表信息,更改user表,随便你怎么改
  • 打赏
  • 举报
回复
瑶子1 2011-07-28
这个问题我差点疯了!还是解决了!
基本上的安装步骤大家都清楚,如果出现上述的安装错误,先在控制面板删除,在到安装路径删除
1、改变安装路径
2、其他安装照旧
3、在please set the windows service(这个页面选取:Include bin directory in windows path)
4、进行下一步就可以了!
如果在添加密码时有三个框,都填一样就可以了!
  • 打赏
  • 举报
回复
babykura 2011-07-27
我现在就出现这个问题吖 解决不到吖 泪
  • 打赏
  • 举报
回复
ctxinxing 2011-06-26
[Quote=引用 3 楼 acmain_chm 的回复:]
那是在LINUX下的命令,换成WINDOWS下的就可以了。

到WINDOWS的命令行了(‘DOS’ 下),切换到你的MySQL bin目录下。 比如我的是 C:\Program Files\MySQL\MySQL Server 5.1\bin
然后敲下面的粗体的命令。注意你的my.ini位置。

C:\Program Files\MySQL\MySQL Server 5.1\bin>m……
[/Quote]
按照三楼的方法做完后 再按照楼主的第一个方法写下去就可以吗
  • 打赏
  • 举报
回复
ctxinxing 2011-06-26
[Quote=引用 3 楼 acmain_chm 的回复:]
那是在LINUX下的命令,换成WINDOWS下的就可以了。

到WINDOWS的命令行了(‘DOS’ 下),切换到你的MySQL bin目录下。 比如我的是 C:\Program Files\MySQL\MySQL Server 5.1\bin
然后敲下面的粗体的命令。注意你的my.ini位置。

C:\Program Files\MySQL\MySQL Server 5.1\bin>m……
[/Quote]

按照你的做法我出现如下错误是什么意思 谢谢
C:\Program Files\MySQL\MySQL Server 5.1\bin>mysqld --defaults-file="C:\Program
Could not open required defaults file: C:\Program
Fatal error in defaults handling. Program aborted
110626 22:26:27 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Se
rver 5.1\data\microsof-679b67.lower-test
110626 22:26:27 [Warning] Can't create test file C:\Program Files\MySQL\MySQL Se
rver 5.1\data\microsof-679b67.lower-test
mysqld: Can't change dir to 'C:\Program Files\MySQL\MySQL Server 5.1\data\' (Err
code: 2)
110626 22:26:27 [ERROR] Aborting

110626 22:26:27 [Note] mysqld: Shutdown complete


C:\Program Files\MySQL\MySQL Server 5.1\bin>Files\MySQL\MySQL Server 5.1\my.ini"
--console --skip-grant-tables
系统找不到指定的路径。

C:\Program Files\MySQL\MySQL Server 5.1\bin>
  • 打赏
  • 举报
回复
加载更多回复
相关推荐
发帖
MySQL
加入

5.5w+

社区成员

MySQL相关内容讨论专区
申请成为版主
帖子事件
创建了帖子
2009-05-15 09:22
社区公告
暂无公告