eclipse无法启动,没有错误提示,双击后一闪就没了

qiubi 2009-07-20 11:44:39
刚下载的eclipse双击后只是闪了一下启动的界面就什么都没了,无法启动,没有任何错误提示信息,JDK是一直在用的,环境变量配置方面没有问题,java、jsp程序运行正常,NetBean使用正常,就是无法启动eclipse,而且换了eclipse的不同版本还是同样的问题

附:JDK1.6.0_07、Eclipse-SDK-3.5
...全文
9600 点赞 收藏 30
写回复
30 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
anyang777 2012-09-03
18楼威武!!!我也解决了。
回复
chen_mcgrady 2012-08-22
18楼大牛
回复
chen_mcgrady 2012-08-22
18楼大牛啊
回复
lxcdn_2011 2012-08-02
[Quote=引用 18 楼 的回复:]

右键点 eclipse.exe 复制为快捷捷。

再右键点快捷按钮eclipse.exe,选择属性,参考如下方式配置“目标”

D:\eclipse\eclipse.exe -vm "C:\jdk1.6.0\bin\javaw.exe" -data D:\java91

第一个参数是eclipse.exe的位置,第二个参数是配置JDK,第三个参数是配置你的ECLIPSE工作空间

……
[/Quote]
通过上述方法,我的问题也解决了。
回复
oyto12o 2011-10-07
[Quote=引用 25 楼 javametro 的回复:]

谢谢,我也出了这个状况。
使用这个方法后搞定了。引用 18 楼 java91 的回复:

右键点 eclipse.exe 复制为快捷捷。

再右键点快捷按钮eclipse.exe,选择属性,参考如下方式配置“目标”

D:\eclipse\eclipse.exe -vm "C:\jdk1.6.0\bin\javaw.exe" -data D:\java91

第一个参数是ecl……
[/Quote]

这个方法很好,我也解决了
回复
javametro 2011-08-30
谢谢,我也出了这个状况。
使用这个方法后搞定了。[Quote=引用 18 楼 java91 的回复:]

右键点 eclipse.exe 复制为快捷捷。

再右键点快捷按钮eclipse.exe,选择属性,参考如下方式配置“目标”

D:\eclipse\eclipse.exe -vm "C:\jdk1.6.0\bin\javaw.exe" -data D:\java91

第一个参数是eclipse.exe的位置,第二个参数是配置JDK,第三个参数是配置你的ECLIPSE工作空间

……
[/Quote]
回复
wzl369 2009-11-23
我知道是什么问题了,你装了多个不同版本的JDk导致的,我也出现了这种情况,卸载了其中一个,设置好环境变量就行了
回复
Gray09 2009-09-24
我也遇到同样的现象,正如22楼所述,关闭360就可以正常启动。 到底是怎么回事还是不清楚。
回复
54xx 2009-08-02
确实我升级最新的360后,eclipse出现无法打开的情况,但是有提示,修改ini文件后可以启动了,把
-Dosgi.requiredJavaVersion=1.5
-Xms40m
-Xmx512m
这项里面的-Xmx512m 改成 -Xmx256m 可以成功启动
后来再修改原状后,依然无法启动。把360关闭后,就可以启动了!
回复
xwizard1234 2009-07-31
刚刚我也碰到这个问题。把360安全卫士关了再开就可以了!
回复
qiubi 2009-07-26
多谢大家的支持和帮助,最后还是老样子,不想折腾了,也不想重新装JDK或系统之类的。我现在改用MyEclipse7.5了。

MyEclipse使用很正常,没有任何问题。
回复
taotaoyue 2009-07-25
用 cmd
用这个启动eclipse.exe
看一下有什么提示没?
回复
java91 2009-07-24
右键点 eclipse.exe 复制为快捷捷。

再右键点快捷按钮eclipse.exe,选择属性,参考如下方式配置“目标”

D:\eclipse\eclipse.exe -vm "C:\jdk1.6.0\bin\javaw.exe" -data D:\java91

第一个参数是eclipse.exe的位置,第二个参数是配置JDK,第三个参数是配置你的ECLIPSE工作空间

这样还不行的话,我无语了。
回复
login_user 2009-07-24
我的也是,而且我的机器右键我的电脑打不开属性窗口!!!!!!
回复
pilotyyc 2009-07-24
楼主用的是最新版本的Eclipse,会不会是新版本的Bug?

如果一闪而过,没有什么错误提示(系统提示)的话,我想可能会是软件之间的冲突。楼主在用其他一些老版本的Eclipse的时候也有同样的现象,之前有过类似的现象吗?换句话说,之前楼主一直是在用NetBean吗?
回复
sfwhhp 2009-07-23
[Quote=引用 4 楼 lytcd 的回复:]
很奇怪的问题 没遇到过

如果是换了几个版本都不行,建议楼主 把你机子上的 jdk重装下,环境变量之类的重新配置下```
是在不行``系统重装了```再不行 就换电脑``再不行就米得办法了``
[/Quote]

这位仁兄,不说也罢
回复
qiubi 2009-07-21
[Quote=引用 2 楼 jia_zimo 的回复:]
装的有问题,用 myeclipse
[/Quote]

eclipse是不用安装的啊,解压后就可以直接运行的
这个问题真搞死人了,不知道什么原因,网上很多关于无法启动eclipse的案例,但他们一般都是有错误提示的,一般能找到问题的根源,但我这里真的不知道怎么办了。换了几个版本都不行
回复
Jia_Zimo 2009-07-21
装的有问题,用 myeclipse
回复
qiubi 2009-07-21
有兄弟姐妹遇到过类似的情况么?帮帮啦……
回复
qiubi 2009-07-21
[Quote=引用 11 楼 shengnba 的回复:]
看看eclipse目录下的eclipse.ini文件,是不是里面的-XX:MaxNewSize=256m -XX:MaxPermSize=256m
256m
-vmargs
-Xms515m
-Xmx512m
这些参数设置过大或过小所致
[/Quote]
改了,不起作用
回复
加载更多回复
相关推荐
发帖
Eclipse
创建于2007-09-28

5.8w+

社区成员

Java Eclipse
申请成为版主
帖子事件
创建了帖子
2009-07-20 11:44
社区公告
暂无公告