到主机 的 TCP/IP 连接失败 救命啊.要疯了

wujia2009 2009-07-31 12:44:47
SQL Server Configuraction Manager中 mssqlserver协议启动,还是sqlexpress的协议启动.

启动mssqlserver协议mssqlserver服务开不了.

启动sqlexpress协议.sqlexpress服务开不了.

机器重装.用的是sp3系统.是不是sqlserver2005要打什么补丁???? 哪位告诉下.要崩溃了
...全文
99 5 打赏 收藏 转发到动态 举报
写回复
用AI写文章
5 条回复
切换为时间正序
请发表友善的回复…
发表回复
MinThinking 2009-07-31
  • 打赏
  • 举报
回复
我以前用过,记得sql2005是要打补丁的!
DoctorWeir 2009-07-31
  • 打赏
  • 举报
回复
你的服务都没开启成功怎么连?重新安装sql2005

SQL Server 2005 默认打开的内存共享而非tcp/ip连接,必须打开此连接才可以.

langxiashahai 2009-07-31
  • 打赏
  • 举报
回复
你启动mssqlserver这个服务就可以了,sqlserver2005的不需要打补丁,另外在sqlserver Configuration Manager 中把mssqlserver的TCP/IP协议启用就OK了。
xx112233oo 2009-07-31
  • 打赏
  • 举报
回复
在自己本机数据库的配置文件中的SQL Server Configuration manager中的 sqlExpess协议中
TCP/IP 协议时被禁用的 把他开启就好了
bingsha1976 2009-07-31
  • 打赏
  • 举报
回复
在 SQL Server 2005 里面,如果出现到主机 的 TCP/IP 连接失败。 java.net.ConnectException: Connection refused: connect!
估计是因为sqlserver2005默认情况下是禁用了tcp/ip连接。
您可以在命令行输入:telnet localhost 1433进行检查,这时会报错:正在连接到localhost...不能打开到主机的连接,在端口 1433: 连接失败
启动tcp/ip连接的方法:
打开 \Microsoft SQL Server 2005\配置工具\目录下的SQL Server Configuration Manager,选择mssqlserver协议, 然后右边窗口有个tcp/ip协议,然后启动它,把sqlserver服务停了,然后在启动。问题就解决了!
这时在命令行输入:telnet localhost 1433就不会再报错了,窗口显示为一片黑,即为正常。

62,621

社区成员

发帖
与我相关
我的任务
社区描述
Java 2 Standard Edition
社区管理员
  • Java SE
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧