在线紧急求助:JBoss运行时错误

pushboy 2009-08-06 03:10:36
JBOSS4.01,之前一直运行良好,昨天服务器安装补丁,重启之后,一直出现如下错误:

2009-08-06 14:26:26,312 WARN [org.jboss.tm.TransactionImpl] XAException: tx=TransactionImpl:XidImpl[FormatId=257, GlobalId=spcore/170, BranchQual=, localId=170] errorCode=XA_UNKNOWN(0)
org.jboss.resource.connectionmanager.JBossLocalXAException: wrong xid in rollback: expected: null, got: XidImpl[FormatId=257, GlobalId=spcore/170, BranchQual=1, localId=170]
at org.jboss.resource.connectionmanager.TxConnectionManager$LocalXAResource.rollback(TxConnectionManager.java:1019)
at org.jboss.tm.TransactionImpl$Resource.rollback(TransactionImpl.java:2257)
at org.jboss.tm.TransactionImpl.rollbackResources(TransactionImpl.java:1817)
at org.jboss.tm.TransactionImpl.commit(TransactionImpl.java:350)
at org.jboss.aspects.tx.TxPolicy.endTransaction(TxPolicy.java:175)
at org.jboss.aspects.tx.TxPolicy.invokeInOurTx(TxPolicy.java:87)
at org.jboss.aspects.tx.TxInterceptor$Required.invoke(TxInterceptor.java:192)
at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
at org.jboss.aspects.tx.TxPropagationInterceptor.invoke(TxPropagationInterceptor.java:76)
at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
at org.jboss.ejb3.stateless.StatelessInstanceInterceptor.invoke(StatelessInstanceInterceptor.java:54)
at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
at org.jboss.aspects.security.AuthenticationInterceptor.invoke(AuthenticationInterceptor.java:78)
at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
at org.jboss.ejb3.ENCPropagationInterceptor.invoke(ENCPropagationInterceptor.java:47)
at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
at org.jboss.ejb3.asynchronous.AsynchronousInterceptor.invoke(AsynchronousInterceptor.java:106)
at org.jboss.aop.joinpoint.MethodInvocation.invokeNext(MethodInvocation.java:98)
at org.jboss.ejb3.stateless.StatelessContainer.dynamicInvoke(StatelessContainer.java:219)
at org.jboss.aop.Dispatcher.invoke(Dispatcher.java:107)
at org.jboss.aspects.remoting.AOPRemotingInvocationHandler.invoke(AOPRemotingInvocationHandler.java:82)
at org.jboss.remoting.ServerInvoker.invoke(ServerInvoker.java:580)
at org.jboss.remoting.ServerInvoker.invoke(ServerInvoker.java:450)
at org.jboss.remoting.transport.socket.ServerThread.processInvocation(ServerThread.java:290)
at org.jboss.remoting.transport.socket.ServerThread.dorun(ServerThread.java:344)
at org.jboss.remoting.transport.socket.ServerThread.run(ServerThread.java:202)
2009-08-06 14:26:26,314 ERROR [org.jboss.remoting.transport.socket.ServerThread] failed
java.net.SocketException: Connection reset
at java.net.SocketOutputStream.socketWrite(SocketOutputStream.java:96)
at java.net.SocketOutputStream.write(SocketOutputStream.java:136)
at java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:65)
at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:123)
at java.io.ObjectOutputStream$BlockDataOutputStream.flush(ObjectOutputStream.java:1784)
at java.io.ObjectOutputStream.flush(ObjectOutputStream.java:691)
at org.jboss.remoting.serialization.impl.java.JavaSerializationManager.sendObject(JavaSerializationManager.java:87)
at org.jboss.remoting.marshal.serializable.SerializableMarshaller.write(SerializableMarshaller.java:84)
at org.jboss.remoting.transport.socket.ServerThread.processInvocation(ServerThread.java:313)
at org.jboss.remoting.transport.socket.ServerThread.dorun(ServerThread.java:344)
at org.jboss.remoting.transport.socket.ServerThread.run(ServerThread.java:202)


前台应用程序报错为

2009-08-06 14:26:31,453 ERROR [com.a8.smgpcdma.ExecSyncCdmaTask] java.lang.RuntimeException: org.jboss.tm.JBossRollbackException: Unable to commit, tx=TransactionImpl:XidImpl[FormatId=257, GlobalId=spcore/44, BranchQual=, localId=44] status=STATUS_NO_TRANSACTION; - nested throwable: (org.jboss.resource.connectionmanager.JBossLocalXAException: could not commit local tx; - nested throwable: (org.jboss.resource.JBossResourceException: SQLException; - nested throwable: (com.microsoft.sqlserver.jdbc.SQLServerException: COMMIT TRANSACTION 请求没有对应的 BEGIN TRANSACTION。)))



JBoss服务器是在Linux上,前台和数据库是在windows上
请高手帮忙看看
能解决问题再加分
谢谢
...全文
245 4 打赏 收藏 转发到动态 举报
写回复
用AI写文章
4 条回复
切换为时间正序
请发表友善的回复…
发表回复
liwei6234 2009-12-23
  • 打赏
  • 举报
回复
什么性能问题 ,能说明白点么 我今天在部署时也出现了这个问题 ,当服务器刚启动时没有问题 ,一旦等待一会后在点击页面就会爆这个错误

org.jboss.resource.connectionmanager.JBossLocalXAException: wrong xid in rollback: expected: null, got: XidImpl[FormatId=257, GlobalId=spcore/170, BranchQual=1, localId=170]
无·法 2009-08-23
  • 打赏
  • 举报
回复
没遇到过
shuffercheng 2009-08-07
  • 打赏
  • 举报
回复
怎么解决的?我这里weblogic的服务也有报这个错误的
pushboy 2009-08-06
  • 打赏
  • 举报
回复

自己解决了
是因为性能问题导致的

6,786

社区成员

发帖
与我相关
我的任务
社区描述
JBoss技术交流
社区管理员
  • JBoss技术交流社区
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧