Apache mysql php配置连接不上mysql

nooodabc 2009-08-14 08:53:57
Apache mysql php配置连接不上mysql怎么回事,不管我怎么改都连不上,我是菜鸟,请求帮助

我装的是mysql5.3.17
apache2.2.11
php5.3.0
apache可以运行PHP测试也正常,就是连接数据库出了问题

附部分配置信息
PHP配置5.3的和以前的不一样了吗???

[dba]
;dba.default_handler=

; Local Variables:
; tab-width: 4
; End:
[PHP_BZ2]
extension=php_bz2.dll
[PHP_CURL]
extension=php_curl.dll
[PHP_GD2]
extension=php_gd2.dll
[PHP_GETTEXT]
extension=php_gettext.dll
[PHP_IMAP]
extension=php_imap.dll
[PHP_MBSTRING]
extension=php_mbstring.dll
[PHP_MYSQL]
extension=php_mysql.dll
[PHP_MYSQLI]
extension=php_mysqli.dll
[PHP_OPENSSL]
extension=php_openssl.dll
[PHP_PDO_MYSQL]
extension=php_pdo_mysql.dll
[PHP_PDO_ODBC]
extension=php_pdo_odbc.dll
[PHP_PDO_SQLITE]
extension=php_pdo_sqlite.dll
[PHP_PGSQL]
extension=php_pgsql.dll
[PHP_SOAP]
extension=php_soap.dll
[PHP_SOCKETS]
extension=php_sockets.dll
[PHP_SQLITE3]
extension=php_sqlite3.dll
[PHP_TIDY]
extension=php_tidy.dll
[PHP_XMLRPC]
extension=php_xmlrpc.dll
[PHP_EXIF]
extension=php_exif.dll

APACHE的配置信息
#BEGIN PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
PHPIniDir "C:/PHP/"
LoadModule php5_module "C:/PHP/php5apache2_2.dll"
#END PHP INSTALLER EDITS - REMOVE ONLY ON UNINSTALL
PHP5.3安装程序自己干添加上去的
...全文
800 点赞 收藏 10
写回复
10 条回复
切换为时间正序
请发表友善的回复…
发表回复
sinbasara 2012-05-01
对,出错信息贴出来才靠谱
[Quote=引用 8 楼 的回复:]

贴SQL语句先。
[/Quote]
回复
zlyr12345 2012-05-01
我的apache正常安装后,在配置时如果加上
LoadFile "D:/program/php5/libmysql.dll"
LoadModule php5_module D:/program/php5/php5apache2_2.dll
这两句就不能运行是怎么回事啊
回复
LuciferStar 2011-09-11
贴SQL语句先。
回复
黄袍披身 2011-09-11
先弄清楚你的mysql 运行起来没有.
cmd
telnet
open localhost 3306

看看返回信息
回复
gz109 2011-09-10
难道出问题就用集成环境么。。。。
回复
liyilin_11 2011-09-10
You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax line 1
回复
第一,楼主的信息可能是无助的信息。Mysql在php.ini下应该没有有用的信息。
第二,楼主启动一下mysql,然后在console模式下试试看看。
第三,有可能有端口的冲突(Oracle 端口也是3306),记得是用ping来试试看看,
最后,若是想省点心,用集成的包会容易一点。比如WAMP, XAMPP,AppServ等,更方便一些。
回复
ccdnleo 2011-09-09
建议楼主下载个wramp集成环境安装一次就可以了,至于环境配置里的东西只要知道是什么作用就行,手动一个一个的配置很容易出错。
回复
黄袍披身 2011-09-07
[Quote=引用 1 楼 fffy2366 的回复:]

莫非LZ也是用的Win7 ?
[/Quote]

跟win7无关 我就在用win7.检查mysql 是否正常启动.没有的话 自己下个mysql安装包来安装即可.
回复
fffy2366 2011-09-07
莫非LZ也是用的Win7 ?
回复
发动态
发帖子
基础编程
创建于2007-09-28

2.1w+

社区成员

从PHP安装配置,PHP入门,PHP基础到PHP应用
申请成为版主
社区公告
暂无公告