求助JBOSS4.2.3下JMS简单例子问题。
启动之后提示了:
[A] Bound to JNDI name: queue/A
[B] Bound to JNDI name: queue/B
[C] Bound to JNDI name: queue/C
[D] Bound to JNDI name: queue/D
[ex] Bound to JNDI name: queue/ex
[testTopic] Bound to JNDI name: topic/testTopic
[securedTopic] Bound to JNDI name: topic/securedTopic
但是我写程序调用的时候就出错了。
Hashtable env = new Hashtable();
env.put(Context.INITIAL_CONTEXT_FACTORY,
"org.jnp.interfaces.NamingContextFactory");
env.put(Context.PROVIDER_URL, "localhost:1099");
env.put("java.naming.rmi.security.manager", "yes");
env.put(Context.URL_PKG_PREFIXES, "org.jboss.naming");
[Root exception is javax.naming.CommunicationException: Failed to connect to server localhost:1099 [Root exception is javax.naming.ServiceUnavailableException: Failed to connect to server localhost:1099 [Root exception is java.net.ConnectException: Connection refused]]]
哪里配置出问题了呢?