apache 提示You don't have permission to access /< on this server怎样解决

yueyang 2001-10-31 12:26:10
如果解决了这个问题,你如果去楼下我的帖子里,我那个帖子的分也给你。楼下的那个标题的问题我已解决。
...全文
4249 点赞 收藏 3
写回复
3 条回复
zjnbgda 2001年10月31日
这个问题应该好解决,只要改变你的<Directory "path"></Directory>,将里面的path改成你的调试目录就可以了。
回复 点赞
yueyang 2001年10月31日
作者:高辉

电邮: kouvin@21cn.com; kouvin@fm365.com kouvin@china.com



关键字: Apache 403 Forbidden



系统配置:

操作系统:Red Hat Linux 6.2

Web服务器:Apache 3.1.1+jakarta-tomcat 3.1.1

数据库服务器:oracle 8i



Apache服务器是目前应用最多的web服务器,据统计在世界上的服务器中有超过一半采用Apache服务器.关于它的好处,您可以自己到www.apache.org上去看。



今天我们的服务器出了一点儿问题:任何访问都会返回一个403的错误:

Forbidden

You don't have permission to access on this server。

不对呀,原来还好好的,在排除了目录的权限等的问题外,我几乎翻遍了系统的所有文件,尤其是/etc/httpd/conf下的所有配置文件,因为我已经将access.conf,srm.conf文件加入到httpd.conf文件中,同时在httpd.conf文件的最后加上了一句:

Include /etc/httpd/conf/tomcat.conf,以便将tomcat和apache连接起来。

在经过了一番思考之后,我认为问题肯定出在httpd.conf文件中,于是就又重新检查httpd.conf文件,终于让我发现了其中有这样一段:

<Files ~>

AllowOverride AuthConfig FileInfo Indexs Limit Options

Order allow ,deny

Deny from all-----------------注意:就是这儿!!

</Files>

心头一阵狂喜,哈哈,想起赵本山说的一句话“小样儿,脱了马甲我也认得你”,于是改成:

Allow from all,重新启动服务器,咦,还是不行?头开始大了,心想:今儿个我是载这儿了。又翻了n多遍httpd.conf文件几乎都要背下来了还找不到问题。也怪,突然就想起来了,www.apache.org不是有个问题数据库吗,几乎所有的问题都可以在上面找到答案,于是进入http://bugs.apache.org/,查找关键字forbidden,果然就让我查到了,原来是我们一位同事想做一个虚拟主机,用了linux的配置工具linuxconf,这个工具因为版本的问题,会导致httpd.conf文件的修改,其实我只要将上面的那一段去掉就可以万事大吉了。



最终总结经验:遇到事情首先要想到到软件所在的网站上找答案,免得浪费时间。



写此文的目的:以我为反面教材,遇到问题不要自己总是认为自己可以解决,而不到专业网站上请教。很多的网站已经有了非常完善的faq,基本上可以满足大家平时的需求,比如pb的要多到www.sybase.com上走走,java到http://developer.java.sun.com上转转,vc到坏孩子家溜溜。其实一些高手不是他们有多聪明,而是他们懂得如何从有用的地方找到自己想要的东西。

我也象他那样找到了希望,也没管用。后来我乐了,但后来我又乐不起来了。那着在我这里不行啊?谁能帮我?我找!我找!不行就自救。
回复 点赞
yueyang 2001年10月31日
调试目录你指的是哪一项?
是指我放PHP文件和HTML文件的地方吗?
<Directory /php4/test/>
Options ALL
AllowOverride None
</Directory>
<Directory "C:/Apache/htdocs">
Options All
AllowOverride None
Order allow,deny
Allow from all
</Directory>
还是不行啊
回复 点赞
发动态
发帖子
基础编程
创建于2007-09-28

9733

社区成员

14.0w+

社区内容

从PHP安装配置,PHP入门,PHP基础到PHP应用
社区公告
暂无公告