关于安装Mysql时遇到问题,来者有分不够再加!

renfei0730 2009-12-26 01:29:20
安装Mysql时遇到问题,提示libc.so.6(Glibc_2.3.4) is needed by Mysql……
libpthread.so.0(Glibc_2.3.4)is needed by ……
rtld(GUN_hash)is needed by ……
请问我该如何继续安装,在lib目录下发现存在libc.so.6怎么出现这种提示,我的环境redhat linux9
...全文
73 点赞 收藏 12
写回复
12 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
iisbsd 2009-12-28
[Quote=引用 10 楼 renfei0730 的回复:]
有人说这个系统比较稳定,教程也相对较多!
[/Quote]

我不用,所以我的观点可能不正确,但是使用一个官方已经停止支持的版本实在是需要勇气的,说它稳定,不如说已经停止更新。

不知道你要什么样的教程,现在Fedora,CentOS,Ubuntu和Debian都很普遍,而Fedora和Ubuntu的易用性已经很好用了。如果你用于服务器,Fedora/CentOS和Red Hat使用上也差不多。
回复
ydy4618 2009-12-27
yum安装自动解决包依赖
回复
renfei0730 2009-12-27
[Quote=引用 5 楼 francis86 的回复:]
这是软件包依赖问题啊

楼主一次安装顺序将上面needed by后面的软件装好后在安装前面的软件
以此类推,最终可以成功安装。

[/Quote]

这也太郁闷了,其中有个needed by 就是 我要安装的mysql5,装不上啊!哈哈,方法不可行。
最后我换了个mysql的版本4.1就装上了,不知道这个5.1版本怎么装上!
回复
SADSDSDDASDASD 2009-12-27
我建议你还是下载那个自己编译的包装吧 就是麻烦点 但比较靠谱 rpm 有依赖问题的
回复
renfei0730 2009-12-27
[Quote=引用 9 楼 iisbsd 的回复:]
我很好奇,为什么现在还有人在用RedHat 9,有什么特殊原因么?
[/Quote]

有人说这个系统比较稳定,教程也相对较多!
回复
iisbsd 2009-12-27
我很好奇,为什么现在还有人在用RedHat 9,有什么特殊原因么?
回复
taffy5366 2009-12-26
不行就用yum安装
回复
francis86 2009-12-26
这是软件包依赖问题啊

楼主一次安装顺序将上面needed by后面的软件装好后在安装前面的软件
以此类推,最终可以成功安装。
回复
renfei0730 2009-12-26
[Quote=引用 3 楼 lgxwqq111 的回复:]
源代码安装的还是包安装的
可能是路径问题,有的需要改相应的so.conf文件吧,以前弄过,快忘了
[/Quote]
rpm 安装
回复
freetstar 2009-12-26
源代码安装的还是包安装的
可能是路径问题,有的需要改相应的so.conf文件吧,以前弄过,快忘了
回复
wzwen 2009-12-26
libc.so.6是不是要重新安装下???

回复
wuguanlin 2009-12-26
不懂....
回复
相关推荐
发帖
系统维护与使用区
创建于2007-08-27

1.9w+

社区成员

系统使用、管理、维护问题。可以是Ubuntu, Fedora, Unix等等
申请成为版主
帖子事件
创建了帖子
2009-12-26 01:29
社区公告
暂无公告