Jboss 5.1 + JDK1.6 deploy war 出错

atlandis_JL 2009-12-28 03:18:11
Jboss 5.1 + JDK1.6 deploy war 出错


请问大家下面的问题谁遇到过,怎么解决?

环境:windows 2003 + JBoss5.1 + JDK1.6
发布war文件后出现如下错误信息:

ERROR [org.jboss.kernel.plugins.dependency.AbstractKernelController] (HDScanner) Error installing to Parse: name=vfszip:/D:/ApplicationServer/jboss51/server/default/deploy/pet_world.war/ state=Not Installed mode=Manual requiredState=Parse
org.jboss.deployers.spi.DeploymentException: Error creating managed object for vfszip:/D:/ApplicationServer/jboss51/server/default/deploy/pet_world.war/
at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)
at org.jboss.deployers.spi.deployer.helpers.AbstractParsingDeployerWithOutput.createMetaData(AbstractParsingDeployerWithOutput.java:362)
at org.jboss.deployers.spi.deployer.helpers.AbstractParsingDeployerWithOutput.createMetaData(AbstractParsingDeployerWithOutput.java:322)
at org.jboss.deployers.spi.deployer.helpers.AbstractParsingDeployerWithOutput.createMetaData(AbstractParsingDeployerWithOutput.java:294)
at org.jboss.deployers.spi.deployer.helpers.AbstractParsingDeployerWithOutput.deploy(AbstractParsingDeployerWithOutput.java:234)
at org.jboss.deployers.plugins.deployers.DeployerWrapper.deploy(DeployerWrapper.java:171)
at org.jboss.deployers.plugins.deployers.DeployersImpl.doDeploy(DeployersImpl.java:1439)
at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentFirst(DeployersImpl.java:1157)
at org.jboss.deployers.plugins.deployers.DeployersImpl.install(DeployersImpl.java:1098)
at org.jboss.dependency.plugins.AbstractControllerContext.install(AbstractControllerContext.java:348)
at org.jboss.dependency.plugins.AbstractController.install(AbstractController.java:1631)
at org.jboss.dependency.plugins.AbstractController.incrementState(AbstractController.java:934)
at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:1082)
at org.jboss.dependency.plugins.AbstractController.resolveContexts(AbstractController.java:984)
at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:822)
at org.jboss.dependency.plugins.AbstractController.change(AbstractController.java:553)
at org.jboss.deployers.plugins.deployers.DeployersImpl.process(DeployersImpl.java:781)
at org.jboss.deployers.plugins.main.MainDeployerImpl.process(MainDeployerImpl.java:702)
at org.jboss.system.server.profileservice.repository.MainDeployerAdapter.process(MainDeployerAdapter.java:117)
at org.jboss.system.server.profileservice.hotdeploy.HDScanner.scan(HDScanner.java:362)
at org.jboss.system.server.profileservice.hotdeploy.HDScanner.run(HDScanner.java:255)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:98)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:181)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:205)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)
Caused by: org.jboss.xb.binding.JBossXBException: Failed to parse source: java.io.IOException: Entry no longer available: WEB-INF/web.xml in file D:\ApplicationServer\jboss51\server\default\deploy\pet_world.war
at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.parse(SaxJBossXBParser.java:203)
at org.jboss.xb.binding.UnmarshallerImpl.unmarshal(UnmarshallerImpl.java:168)
at org.jboss.xb.util.JBossXBHelper.parse(JBossXBHelper.java:189)
at org.jboss.xb.util.JBossXBHelper.parse(JBossXBHelper.java:166)
at org.jboss.deployers.vfs.spi.deployer.SchemaResolverDeployer.parse(SchemaResolverDeployer.java:137)
at org.jboss.deployers.vfs.spi.deployer.SchemaResolverDeployer.parse(SchemaResolverDeployer.java:121)
at org.jboss.deployers.vfs.spi.deployer.AbstractVFSParsingDeployer.parseAndInit(AbstractVFSParsingDeployer.java:256)
at org.jboss.deployers.vfs.spi.deployer.AbstractVFSParsingDeployer.parse(AbstractVFSParsingDeployer.java:188)
at org.jboss.deployers.spi.deployer.helpers.AbstractParsingDeployerWithOutput.createMetaData(AbstractParsingDeployerWithOutput.java:348)
... 28 more
Caused by: java.lang.RuntimeException: java.io.IOException: Entry no longer available: WEB-INF/web.xml in file D:\ApplicationServer\jboss51\server\default\deploy\pet_world.war
at org.jboss.virtual.VFSInputSource.getByteStream(VFSInputSource.java:70)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Source)
at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.parse(SaxJBossXBParser.java:199)
... 36 more
Caused by: java.io.IOException: Entry no longer available: WEB-INF/web.xml in file D:\ApplicationServer\jboss51\server\default\deploy\pet_world.war
at org.jboss.virtual.plugins.context.zip.ZipFileWrapper.openStream(ZipFileWrapper.java:216)
at org.jboss.virtual.plugins.context.zip.ZipEntryContext.openStream(ZipEntryContext.java:1082)
at org.jboss.virtual.plugins.context.zip.ZipEntryHandler.openStream(ZipEntryHandler.java:153)
at org.jboss.virtual.VirtualFile.openStream(VirtualFile.java:230)
at org.jboss.virtual.VFSInputSource.getByteStream(VFSInputSource.java:66)
... 39 more
2009-12-26 17:59:46,264 WARN [org.jboss.system.server.profileservice.hotdeploy.HDScanner] (HDScanner) Failed to process changes
org.jboss.deployers.client.spi.IncompleteDeploymentException: Summary of incomplete deployments (SEE PREVIOUS ERRORS FOR DETAILS):

*** DEPLOYMENTS IN ERROR: Name -> Error

vfszip:/D:/ApplicationServer/jboss51/server/default/deploy/pet_world.war/ -> org.jboss.deployers.spi.DeploymentException: Error creating managed object for vfszip:/D:/ApplicationServer/jboss51/server/default/deploy/pet_world.war/


DEPLOYMENTS IN ERROR:
Deployment "vfszip:/D:/ApplicationServer/jboss51/server/default/deploy/pet_world.war/" is in error due to the following reason(s): java.io.IOException: Entry no longer available: WEB-INF/web.xml in file D:\ApplicationServer\jboss51\server\default\deploy\pet_world.war

at org.jboss.deployers.plugins.deployers.DeployersImpl.checkComplete(DeployersImpl.java:993)
at org.jboss.deployers.plugins.deployers.DeployersImpl.checkComplete(DeployersImpl.java:939)
at org.jboss.deployers.plugins.main.MainDeployerImpl.checkComplete(MainDeployerImpl.java:873)
at org.jboss.system.server.profileservice.repository.MainDeployerAdapter.checkComplete(MainDeployerAdapter.java:128)
at org.jboss.system.server.profileservice.hotdeploy.HDScanner.scan(HDScanner.java:369)
at org.jboss.system.server.profileservice.hotdeploy.HDScanner.run(HDScanner.java:255)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:98)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:181)
at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:205)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
at java.lang.Thread.run(Thread.java:619)
...全文
1253 8 打赏 收藏 转发到动态 举报
写回复
用AI写文章
8 条回复
切换为时间正序
请发表友善的回复…
发表回复
酒樽舞曲 2011-07-24
  • 打赏
  • 举报
回复
there is a bug when you use both jdk 1.6 and jboss 5.1. You may copy the jars in jboss to the jre folder. Reference :http://blog.csdn.net/mcy478643968/archive/2011/01/21/6156685.aspx

create folder:C:\Java\jdk1.6.0_21\jre\lib\endorsed and C:\Java\jdk1.6.0_21\lib\endorsed

jaxb-api.jar
jbossws-native-jaxrpc.jar
jbossws-native-jaxws.jar
jbossws-native-jaxws-ext.jar
jbossws-native-saaj.jar
xercesImpl.jar

copy the jars and it will be fine.
lengyingxin 2011-07-20
  • 打赏
  • 举报
回复
09:03:16,671 ERROR [AbstractKernelController] Error installing to Parse: name=v
sfile:/E:/jboss-eap-5.1/jboss-as/server/production/deploy/COM-ORCH-2.0.ear/ sta
e=PreParse mode=Manual requiredState=Parse
org.jboss.deployers.spi.DeploymentException: Error creating managed object for
fsfile:/E:/jboss-eap-5.1/jboss-as/server/production/deploy/COM-ORCH-2.0.ear/ORC
-web-2.0.war/
at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentExcep
ion(DeploymentException.java:49)
at org.jboss.deployers.spi.deployer.helpers.AbstractParsingDeployerWith
utput.createMetaData(AbstractParsingDeployerWithOutput.java:362)
at org.jboss.deployers.spi.deployer.helpers.AbstractParsingDeployerWith
utput.createMetaData(AbstractParsingDeployerWithOutput.java:322)
at org.jboss.deployers.spi.deployer.helpers.AbstractParsingDeployerWith
utput.createMetaData(AbstractParsingDeployerWithOutput.java:294)
at org.jboss.deployers.spi.deployer.helpers.AbstractParsingDeployerWith
utput.deploy(AbstractParsingDeployerWithOutput.java:234)
at org.jboss.deployers.plugins.deployers.DeployerWrapper.deploy(Deploye
Wrapper.java:179)
at org.jboss.deployers.plugins.deployers.DeployersImpl.doDeploy(Deploye
sImpl.java:1454)
at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentF
rst(DeployersImpl.java:1172)
at org.jboss.deployers.plugins.deployers.DeployersImpl.doInstallParentF
rst(DeployersImpl.java:1225)
at org.jboss.deployers.plugins.deployers.DeployersImpl.install(Deployer
Impl.java:1113)
at org.jboss.dependency.plugins.AbstractControllerContext.install(Abstr
ctControllerContext.java:348)
at org.jboss.dependency.plugins.AbstractController.install(AbstractCont
oller.java:1652)
at org.jboss.dependency.plugins.AbstractController.incrementState(Abstr
ctController.java:938)
at org.jboss.dependency.plugins.AbstractController.resolveContexts(Abst
actController.java:1082)
at org.jboss.dependency.plugins.AbstractController.resolveContexts(Abst
actController.java:988)
at org.jboss.dependency.plugins.AbstractController.change(AbstractContr
ller.java:826)
at org.jboss.dependency.plugins.AbstractController.change(AbstractContr
ller.java:556)
at org.jboss.deployers.plugins.deployers.DeployersImpl.process(Deployer
Impl.java:789)
at org.jboss.deployers.plugins.main.MainDeployerImpl.process(MainDeploy
rImpl.java:699)
at org.jboss.system.server.profileservice.repository.MainDeployerAdapte
.process(MainDeployerAdapter.java:117)
at org.jboss.system.server.profileservice.repository.ProfileDeployActio
.install(ProfileDeployAction.java:70)
at org.jboss.system.server.profileservice.repository.AbstractProfileAct
on.install(AbstractProfileAction.java:53)
at org.jboss.system.server.profileservice.repository.AbstractProfileSer
ice.install(AbstractProfileService.java:403)
at org.jboss.dependency.plugins.AbstractControllerContext.install(Abstr
ctControllerContext.java:348)
at org.jboss.dependency.plugins.AbstractController.install(AbstractCont
oller.java:1652)
at org.jboss.dependency.plugins.AbstractController.incrementState(Abstr
ctController.java:938)
at org.jboss.dependency.plugins.AbstractController.resolveContexts(Abst
actController.java:1082)
at org.jboss.dependency.plugins.AbstractController.resolveContexts(Abst
actController.java:988)
at org.jboss.dependency.plugins.AbstractController.install(AbstractCont
oller.java:778)
at org.jboss.dependency.plugins.AbstractController.install(AbstractCont
oller.java:543)
at org.jboss.system.server.profileservice.repository.AbstractProfileSer
ice.registerProfile(AbstractProfileService.java:308)
at org.jboss.system.server.profileservice.ProfileServiceBootstrap.start
ProfileServiceBootstrap.java:256)
at org.jboss.bootstrap.AbstractServerImpl.start(AbstractServerImpl.java
461)
at org.jboss.Main.boot(Main.java:221)
at org.jboss.Main$1.run(Main.java:556)
at java.lang.Thread.run(Thread.java:619)
Caused by: org.jboss.xb.binding.JBossXBException: Failed to parse source: The c
ntent of element type "ejb-local-ref" must match "(description?,ejb-ref-name,ej
-ref-type,local-home,local,ejb-link?)". @ vfsfile:/E:/jboss-eap-5.1/jboss-as/se
ver/production/deploy/COM-ORCH-2.0.ear/ORCH-web-2.0.war/WEB-INF/web.xml[228,20]
at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.parse(SaxJBossXBPar
er.java:203)
at org.jboss.xb.binding.UnmarshallerImpl.unmarshal(UnmarshallerImpl.jav
:168)
at org.jboss.xb.util.JBossXBHelper.parse(JBossXBHelper.java:189)
at org.jboss.xb.util.JBossXBHelper.parse(JBossXBHelper.java:166)
at org.jboss.deployers.vfs.spi.deployer.SchemaResolverDeployer.parse(Sc
emaResolverDeployer.java:137)
at org.jboss.deployers.vfs.spi.deployer.SchemaResolverDeployer.parse(Sc
emaResolverDeployer.java:121)
at org.jboss.deployers.vfs.spi.deployer.AbstractVFSParsingDeployer.pars
AndInit(AbstractVFSParsingDeployer.java:304)
at org.jboss.deployers.vfs.spi.deployer.AbstractVFSParsingDeployer.pars
AndInit(AbstractVFSParsingDeployer.java:286)
at org.jboss.deployers.vfs.spi.deployer.AbstractVFSParsingDeployer.pars
(AbstractVFSParsingDeployer.java:203)
at org.jboss.deployers.spi.deployer.helpers.AbstractParsingDeployerWith
utput.createMetaData(AbstractParsingDeployerWithOutput.java:348)
... 34 more
Caused by: org.xml.sax.SAXException: The content of element type "ejb-local-ref
must match "(description?,ejb-ref-name,ejb-ref-type,local-home,local,ejb-link?
". @ vfsfile:/E:/jboss-eap-5.1/jboss-as/server/production/deploy/COM-ORCH-2.0.e
r/ORCH-web-2.0.war/WEB-INF/web.xml[228,20]
at org.jboss.xb.binding.parser.sax.SaxJBossXBParser$MetaDataErrorHandle
.error(SaxJBossXBParser.java:426)
at org.apache.xerces.util.ErrorHandlerWrapper.error(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
at org.apache.xerces.impl.XMLErrorReporter.reportError(Unknown Source)
at org.apache.xerces.impl.dtd.XMLDTDValidator.handleEndElement(Unknown
ource)
at org.apache.xerces.impl.dtd.XMLDTDValidator.endElement(Unknown Source

at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanEndElement(Unkno
n Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentConten
Dispatcher.dispatch(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocument(U
known Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source)
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown Sou
ce)
at org.jboss.xb.binding.parser.sax.SaxJBossXBParser.parse(SaxJBossXBPar
er.java:199)
... 43 more
09:03:30,640 WARN [config] jacorb.home unset! Will use '.'
我也遇到了类似的问题,求解答!我的时jboss-eap-5.1,jdk1.6.0_21
hbu_zhy 2011-07-20
  • 打赏
  • 举报
回复
"Caused by: org.jboss.xb.binding.JBossXBException: Failed to parse source: The c
ntent of element type "ejb-local-ref" must match "(description?,ejb-ref-name,ej
-ref-type,local-home,local,ejb-link?)". @ vfsfile:/E:/jboss-eap-5.1/jboss-as/se
ver/production/deploy/COM-ORCH-2.0.ear/ORCH-web-2.0.war/WEB-INF/web.xml[228,20]"
这句话最有用,web.xml好像配置有问题。
atlandis_JL 2010-01-04
  • 打赏
  • 举报
回复
我刚才没仔细看。
你遇到的问题,应该和我的不太一致,导致我这个错误的原因,应该同jdk5.0和jdk6.0处理vfszip不一致导致的。
[Quote=引用 3 楼 darkkid00 的回复:]
哥们我和你一样的问题,愁死我了
6:29,359 ERROR [AbstractKernelController] Error installing to Start: name=jboss.web.deployment:war=/SSEJBDemoWeb state=Create mode=Manual requiredState=Installed
org.jboss.deployers.spi.DeploymentException: URL file:/E:/jboss-5.1.0.GA/server/default/deploy/SSEJBDemo.ear/SSEJBDemoWeb.war/ deployment failed
at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)
at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeployInternal(TomcatDeployment.java:316)
at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeploy(TomcatDeployment.java:142)
at org.jboss.web.deployers.AbstractWarDeployment.start(AbstractWarDeployment.java:461)
at org.jboss.web.deployers.WebModule.startModule(WebModule.java:118)
at org.jboss.web.deployers.WebModule.start(WebModule.java:97)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.jboss.mx.interceptor.ReflectedDispatcher.in


at java.lang.Thread.run(Thread.java:619)
Caused by: LifecycleException:  Error initializaing :  javax.management.ReflectionException: Cannot find method addChild with this signature
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4150)
at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeployInternal(TomcatDeployment.java:310)
... 62 more
[/Quote]
atlandis_JL 2010-01-04
  • 打赏
  • 举报
回复
哥们,你用jdk5.0多语言版本+JBoss5.1 GA版本,就没有问题了。
但我现在使用jdk6.0,怎么弄都不行。
另外问你一下,你使用哪种方法压缩成war文件的?
darkkid00 2009-12-31
  • 打赏
  • 举报
回复
哥们我和你一样的问题,愁死我了
6:29,359 ERROR [AbstractKernelController] Error installing to Start: name=jboss.web.deployment:war=/SSEJBDemoWeb state=Create mode=Manual requiredState=Installed
org.jboss.deployers.spi.DeploymentException: URL file:/E:/jboss-5.1.0.GA/server/default/deploy/SSEJBDemo.ear/SSEJBDemoWeb.war/ deployment failed
at org.jboss.deployers.spi.DeploymentException.rethrowAsDeploymentException(DeploymentException.java:49)
at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeployInternal(TomcatDeployment.java:316)
at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeploy(TomcatDeployment.java:142)
at org.jboss.web.deployers.AbstractWarDeployment.start(AbstractWarDeployment.java:461)
at org.jboss.web.deployers.WebModule.startModule(WebModule.java:118)
at org.jboss.web.deployers.WebModule.start(WebModule.java:97)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.jboss.mx.interceptor.ReflectedDispatcher.in


at java.lang.Thread.run(Thread.java:619)
Caused by: LifecycleException: Error initializaing : javax.management.ReflectionException: Cannot find method addChild with this signature
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4150)
at org.jboss.web.tomcat.service.deployers.TomcatDeployment.performDeployInternal(TomcatDeployment.java:310)
... 62 more
atlandis_JL 2009-12-29
  • 打赏
  • 举报
回复
D:/ApplicationServer/jboss51
是jboss在我机器上的安装目录
tracycc 2009-12-28
  • 打赏
  • 举报
回复
D:/ApplicationServer 是你指定的么?

6,786

社区成员

发帖
与我相关
我的任务
社区描述
JBoss技术交流
社区管理员
  • JBoss技术交流社区
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧