用USE打开网上数据库的问题

zbzk2008 2010-01-18 11:33:29
USE \\service\自由传递\123.dbf

如果service这台电脑,设置了访问登录密码,这样上一句执行时,会显示出错.无法正常运行.

错误提示为:其他用户正在使用文件.

如果service这台电脑,没有设置访问登录密码,那么一切正常,可以执行程序.

但问题恰恰是:SERVICE这服务器,必须设访问登录密码的.这样才能控制服务器上的资料,不能随便让别人看到.这怎么办啊??

如果即有登录密码,又能正常打开呢??????
...全文
177 10 打赏 收藏 举报
写回复
10 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
wmpc005 2010-01-23
  • 打赏
  • 举报
回复
use 数据库名 share
这样就可以多人同时访问,前提是你可以联接到数据库,可参照一楼net use......
ycj80 2010-01-23
  • 打赏
  • 举报
回复
程序啟動時把 \\service\自由传递\ 目录映射為本地盤,
退出程序時,斷開本地盤。
wzxcgd 2010-01-21
  • 打赏
  • 举报
回复
同意1楼
mspanwei 2010-01-20
  • 打赏
  • 举报
回复
精彩,支持十豆三!taohua300!
whxfelix 2010-01-19
  • 打赏
  • 举报
回复
不懂,up 起来无条件
wenqiu175260251 2010-01-19
  • 打赏
  • 举报
回复
好帖要使劲顶...
jack_wang0823 2010-01-19
  • 打赏
  • 举报
回复
把 \\service\自由传递\ 这个目录映射到本地 是否更简单一些
十豆三 2010-01-18
  • 打赏
  • 举报
回复
如果手动设置不会,又找不到设置工具,那就将以下内容粘帖到SERVICE这服务器一个文本文件中,然后再文本文件的扩展名.txt 改为 .reg,然后双击执行即可。
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Lsa]
"restrictanonymous"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"restrictanonymous"=dword:00000000
; 以上两行在系统中的位置是:本地安全策略-安全选项-网络访问:不允许SAM帐户和共享
; 的匿名枚举。系统默认值是:已停用。
; 解说:操作系统默认:利用ipc$通道可以建立空连接,匿名枚举出该机有多少帐户。显然
; 有一定的安全隐患。本系统已设为不允许空连接了。以此提高单机拨号上网的安全性。
; 负面影响是局域网不能互访了。要更改一下才可以解决。




[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"limitblankpassworduse"=dword:00000000

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Lsa]
"limitblankpassworduse"=dword:00000000
; 以上两行在系统中的位置是:本地安全策略--安全选项--帐户:使用空白密码的本地帐户
; 只允许进行控制台登录。系统默认值是:已启用。
; 解说:很多人的帐户是不加密码的。这样,当局域网中别的电脑访问本机时,会弹出错误提示:
; 登录失败:用户帐户限制………。这是XP系统的一条安全策略造成的,防止别人趁你空密码时
; 进入你的电脑。如果你觉得无所谓,不必做这些限制,那就把它设为:已停用。


[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\UserAssist\{75048700-EF1F-11D0-9888-006097DEACF9}\Count]
"HRZR_EHAPCY"=hex:0C,00,00,00,26,00,00,00,F0,FB,E5,52,64,95,C6,01
"HRZR_EHAPCY:"P:\JVAQBJF\flfgrz32\sverjnyy.pcy",Jvaqbjf 防火墙"=hex:0C,00,00,00,08,00,00,00,F0,FB,E5,52,64,95,C6,01

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\GloballyOpenPorts\List]
"445:TCP"="445:TCP:LocalSubNet:Enabled:@xpsp2res.dll,-22005"
"137:UDP"="137:UDP:LocalSubNet:Enabled:@xpsp2res.dll,-22001"
"138:UDP"="138:UDP:LocalSubNet:Enabled:@xpsp2res.dll,-22002"
"139:TCP"="139:TCP:LocalSubNet:Enabled:@xpsp2res.dll,-22004"

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\SharedAccess\Epoch]
"Epoch"=dword:000001ED

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Print\Providers]
"LogonTime"=hex:E8,31,8E,4F,64,95,C6,01

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SharedAccess\Parameters\FirewallPolicy\StandardProfile\GloballyOpenPorts\List]
"445:TCP"="445:TCP:LocalSubNet:Enabled:@xpsp2res.dll,-22005"
"137:UDP"="137:UDP:LocalSubNet:Enabled:@xpsp2res.dll,-22001"
"138:UDP"="138:UDP:LocalSubNet:Enabled:@xpsp2res.dll,-22002"
"139:TCP"="139:TCP:LocalSubNet:Enabled:@xpsp2res.dll,-22004"

[HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\SharedAccess\Epoch]
"Epoch"=dword:000001ED
; 以上数值对应系统中的位置:控制面板--防火墙--例外--文件和打印机共享。系统默认:不选。
; 解说:所有的策略都设置好了,局域网依然不能访问,提示:您没有权限使用网络资源,找
; 不到网络路径!呵呵,真是令人火冒三丈!其实XP还有一道关卡,就是防火墙,必须要经过
; 防火墙的允许才行。

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa]
"forceguest"=dword:00000001
; 以上数值对应系统中的位置是:控制面板--管理工具--本地安全策略--本地策略--安全选项,
; 网络访问:本地帐户的共享和安全模式:仅来宾-本地用户以来宾份验证。这时,当局域网
; 其他机访问本机时,不会弹出对话框,就可以直接进入。在家庭网等完全可以信任的区域,
; 建议使用这种方式。


;《GhostXP_SP2电脑公司特别版》作者编写。感谢您的使用。
十豆三 2010-01-18
  • 打赏
  • 举报
回复
或者将SERVICE这服务器的 GUEST 用户启用,也就是免密码来宾方式,这个方面工具很多,也可以手动设置服务。

这样访问者无需用户名及密码可以直接访问你的共享目录
taohua300 2010-01-18
  • 打赏
  • 举报
回复
在打开表之前使用一个CMD命令对SERVISE建立一个连接
net use \\计算机名(或IP地址) 密码(带引号) /user:“用户名”
例:
net use \\192.168.18.25 "mima" /user:"admin"

也可以把它写入批处理中,然后在VFP中运行批处理就可以了
相关推荐
发帖
VFP

2576

社区成员

VFP,是Microsoft公司推出的数据库开发软件,用它来开发数据库,既简单又方便。
社区管理员
  • VFP社区
加入社区
帖子事件
创建了帖子
2010-01-18 11:33
社区公告
暂无公告