求助Extjs授权问题.

createWang 2010-02-23 09:01:53
我要商用,如果使用2.0.2版本的话,需要购买吗?就是最后一个公共版本..大侠们知道吗?
...全文
581 10 打赏 收藏 举报
写回复
10 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
小宇巴巴 2011-05-17
  • 打赏
  • 举报
回复
要使用ExtJS,那么首先要得到ExtJS库文件,该框架是一个开源的,可以直接从官方网站下载,网址http://www.dotnetol.com/thread-14-1-1.html,进入下载页面可以看到大致如图所示的内容,当前最新版本是ExtJS4,行业最先进的JavaScript的框架内为建立下一代跨平台的网页浏览器。。
KK3K2005 2010-02-24
  • 打赏
  • 举报
回复
我也想知道具体的 使用许可是什么
luojxun 2010-02-24
  • 打赏
  • 举报
回复
gpl协议就是需要你开源,否则要购买,好像extjs采用的都是gpl协议。不存在2.0不要的问题。
luojxun 2010-02-24
  • 打赏
  • 举报
回复
意思就是在本地可以随便用,开源你的代码也可以随便用,不开源的话就要购买。
lin364653705 2010-02-24
  • 打赏
  • 举报
回复
目前使用的就是2.0,不需要许可!
luojxun 2010-02-24
  • 打赏
  • 举报
回复
LICENSE
Ext JS can be GPL licensed or commercially licensed, which means:

Free to use and test in your local development environment.
Free to use in your website or application, provided you release all of the application’s source code under the GPL. license as well.
Purchase a developer license if you don’t plan on releasing your website or application’s code as open source.
luojxun 2010-02-24
  • 打赏
  • 举报
回复
似乎extjs 2.1开始使用gpl

LGPL也是有限制的不是随便怎么用。

如果修改LGPL协议的代码或者衍生,则所有修改的代码,涉及修改部分的额外代码和衍生的代码都必须采用LGPL协议。

就是说纯粹调用或连接可以不开源,但修改或包含的话就要开源了。
yonglin4605 2010-02-24
  • 打赏
  • 举报
回复
EXT 在2.0版本的时候 遵循的是LGPL协议,随便你怎么用
好像2.2版本之后,更改协议成GPL协议,如果你的项目里用了EXT,并且不开源的话,你要付钱购买授权的
yingzhilian2008 2010-02-23
  • 打赏
  • 举报
回复
还没用过帮顶,以后学习学习
sohighthesky 2010-02-23
  • 打赏
  • 举报
回复
2.x不需要购买的吧
发帖
JavaScript

8.7w+

社区成员

Web 开发 JavaScript
社区管理员
  • JavaScript
  • 无·法
加入社区
帖子事件
创建了帖子
2010-02-23 09:01
社区公告
暂无公告