• 全部
  • 基础类
  • 应用实例
  • 新技术前沿

SQL Server2000的弱智问题,不要说分太少,因为问题简单

hugos 2001-11-13 06:34:42
SqlServer2000安装在win2000server后,只能用windows authentication. SQL 验证死活不行,怎么办?一旦解决马上给分!
...全文
126 点赞 收藏 8
写回复
8 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
21bird 2001-11-14
非常感谢,你可帮了我的大忙啦!!
回复
hugos 2001-11-13
呵呵, 爽死了, 终于搞定了,虽然同志们没有帮上忙,还是散分!
想知道怎么搞定的吗?请看:
MSDE login error


--------------------------------------------------------------------------------


Article ID: KB189

The information in this article applies to MailMarshal and was first reported on July 13, 2001.

DESCRIPTION
You have updated MSDE to service pack 3 or have re-configured database login settings.

SYMPTOMS
Cannot connect to the MailMarshal or WebMarshal Database.
Error: "…….Login failed for user 'sa'. Reason : Not associated with a trusted SQL Server connection……."

CAUSE
MailMarshal and WebMarshal do not support NT Authentication.


WORK AROUND
You need to edit the registry key that tells MailMarshal and WebMarshal how to connect to the database. Open the registry editor by selecting:

Start : Run

Then type "regedit"

When the registry editor opens, go to

"HKEY_LOCAL_MACHINE : SOFTWARE : Microsoft : MSSQLServer : MSSQLServer"

Then double click on the entry that says "LoginMode" and set the value to "0"

"0" (zero) = logon using Mixed Mode Authentication
"1" (one) = logon using Integrated or NT authentication.

You will need to restart your computer for these changes to take effect.

STATUS
Informational Article



Last Reviewed: July 16, 2001
Article ID: KB189


回复
hugos 2001-11-13
同志们
?????????????????
回复
hugos 2001-11-13
如果是第一种情况, 需要重装?
如果是第2种情况, 怎么建?
我已经建了,还是不行
回复
Ganzl 2001-11-13
有两种可能:
1、安装时选择的是“集成安全性”,由windows负责安全审核
2、在SQL Server或数据库中没建相应的用户
回复
hugos 2001-11-13
安全性设置 改了以后,没用,再进去的时候,又变成windows 验证了
回复
hugos 2001-11-13
???????????????
回复
21bird 2001-11-13
当然啊!
好像server下就是这样啊!
回复
相关推荐
发帖
MS-SQL Server
创建于2007-09-28

3.3w+

社区成员

MS-SQL Server相关内容讨论专区
申请成为版主
帖子事件
创建了帖子
2001-11-13 06:34
社区公告
暂无公告