请问:WinCE500下没有Private目录,是什么原因?

Peasant_Lee 2010-06-07 11:17:25
各位兄台,你们好,我最近换了份搞WINCE的工作。彻底脱离了以前单片机和ARM的裸奔。但刚搭环境,就出现了个比较怪的问题。我在公司的PC装WINCE 5.0的环境,在目录WINCE500下没有PRIVATE目录,当然操作系统相关的核心代码也看不见。我在我家里也同样按照WINCE5.0的环境,但它是有PRIVATE目录的(目录下面也有代码)。请问各位,这个是什么原因造成的?我百度和Google过了。没有出现类似的问题,故在此请教。
PRIVATE目录的有与无,究竟是靠什么来决定的? 先谢了。。

...全文
56 点赞 收藏 16
写回复
16 条回复
licaiyuren 2010年07月20日
大锅,你是怎么搞的,到底?copy的??还是重新运行安装程序?
回复 点赞
Peasant_Lee 2010年06月08日
结贴!谢谢各位!
回复 点赞
Peasant_Lee 2010年06月08日
不妨一试!呵呵。。不行再重装。。。怕copy不行,出现什么意外的乱子,到时会误了更多的功夫!
回复 点赞
Ei 2010年06月08日
[Quote=引用 8 楼 yashi 的回复:]
直接拷贝过去不就行了。
[/Quote]
打过patch 应该也会动PRIVATE里面的东西吧。
回复 点赞
Peasant_Lee 2010年06月08日
哈哈,当然了,但是卸载和重装,我公司的机器,至少得花上两个多小时。。。
回复 点赞
yashi 2010年06月08日
直接拷贝过去不就行了。
回复 点赞
Peasant_Lee 2010年06月08日
哎,看来今天早上又得浪费在这上面了。公司的机器又慢,编译生成OS需要接近一个小时啊!简直就是折磨!
谢谢楼上的各位啦。呵呵!
回复 点赞
daifeijin 2010年06月08日
安装的时候 没有选择 Shared Source。
回复 点赞
wolfmvp 2010年06月08日
同情,又得花一二个小时啦…
回复 点赞
Ei 2010年06月08日
最好是 重装下,应该没有什么办法补救
回复 点赞
Peasant_Lee 2010年06月08日
哦,谢谢楼上两位兄弟。我记得在公司和在家里的两次安装都是默认没有打开Shared Source选项的。都是交叉的。现在这种情况,能有什么办法补救不?就是能看到privat目录,而且能正常使用。我不想重装,重装要很长时间。

ARM平台我安装了,呵呵。我听说安装Shared Source选项要申请什么授权的,所以当时可能没有选择它。。。
回复 点赞
huaxu2002 2010年06月08日
楼上说的有道理,在安装PB时默认情况下是没有Shared Source的,所以你在安装时一定要看仔细了,把它选择上,另外注意的是如果你做Arm开发,那么也要选择Arm,这个默认也是未选择的.
回复 点赞
Ei 2010年06月08日
安装的时候 没有选择 Shared Source。
回复 点赞
domworldjohn 2010年06月08日
还是重装保险
回复 点赞
Peasant_Lee 2010年06月08日
哦,呵呵。好的。这个方法,既保险,也方便!谢谢!
回复 点赞
gsymichael 2010年06月08日
重新运行安装程序,在选择的地方单选哪个Share Source就可以追加了。我之前有次也是这样,这么搞就行了
回复 点赞
发动态
发帖子
嵌入开发(WinCE)
创建于2007-09-28

8171

社区成员

4.1w+

社区内容

硬件/嵌入开发 嵌入开发(WinCE)
社区公告
暂无公告