添加soap支持问题 在线等

Matthewzhong 2010-07-09 01:37:19
php中始终无法添加soap支持,请指教
系统环境:
Red Hat Enterprise Linux Server release 5.4
Linux version 2.6.18-164.el5
PHP-5.2.13
...全文
93 7 打赏 收藏 举报
写回复
7 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
CunningBoy 2010-07-09
http://www.zenboss.com/index.php?title=Php_soap&variant=zh-hans

PHP安装SOAP扩展

1.安装php-soap:
yum install php-soap -y

2.在PHP的编译参数中加入--enable-soap,如:
--
./configure --prefix=/usr/local/php-5.2.12 --with-config-file-path=/usr/local/php-5.2.12/etc --enable-fastcgi --enable-force-cgi-redirect --with-curl --with-gd --with-ldap --with-snmp --enable-zip --enable-exif --with-pdo-mysql --with-mysql --with-mysqli --enable-soap
  • 打赏
  • 举报
回复
Dleno 2010-07-09
nusoap吧,不需要PHP有SOAP或其他什么库的支持。
更好用,既可建服务器端又可建客户端。
  • 打赏
  • 举报
回复
CunningBoy 2010-07-09
然后再加--enable-soap编译PHP
  • 打赏
  • 举报
回复
Matthewzhong 2010-07-09
Loaded plugins: rhnplugin, security
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
No package php-soap available.
Nothing to do
  • 打赏
  • 举报
回复
CunningBoy 2010-07-09
试试看
yum install php-soap
  • 打赏
  • 举报
回复
Matthewzhong 2010-07-09
libxml是2.6.26的,用--enable-soap重新编译过了,还是不行
  • 打赏
  • 举报
回复
CunningBoy 2010-07-09
需要下载PHP的原码自己编译,编译时要带--enable-soap参数
编译需要libxml-2.5.4的库
  • 打赏
  • 举报
回复
发帖
基础编程

2.1w+

社区成员

从PHP安装配置,PHP入门,PHP基础到PHP应用
社区管理员
  • 基础编程社区
加入社区
帖子事件
创建了帖子
2010-07-09 01:37
社区公告
暂无公告