springmvc 和 hibernate 整合要怎么配置?

qx8668 2010-09-26 02:36:19

单独的springmvc 配置在web.xml 如下:


<servlet>
<servlet-name>springmvc</servlet-name>
<servlet-class>
org.springframework.web.servlet.DispatcherServlet
</servlet-class>
<init-param>
<param-name>contextConfigLocation</param-name>
<param-value>classpath:/config/spring/spring*.xml</param-value>
</init-param>
<load-on-startup>1</load-on-startup>
</servlet>

<servlet-mapping>
<servlet-name>springmvc</servlet-name>
<url-pattern>*.do</url-pattern>
</servlet-mapping>



通常的配置,和hibernate整合


<context-param>
<param-name>contextConfigLocation</param-name>
<param-value>classpath:/config/spring/spring*.xml</param-value>
</context-param>
<listener>
<listener-class>
org.springframework.web.context.ContextLoaderListener
</listener-class>
</listener>



org.springframework.web.context.ContextLoaderListener

org.springframework.web.servlet.DispatcherServlet

两个用到不同的类,要怎么整合在同一个web.xml

...全文
57 点赞 收藏 5
写回复
5 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
qx8668 2010-09-26
[Quote=引用 4 楼 soli11722984 的回复:]
你的IDE的JDK环境和服务器的JDK环境版本不对吧

应该是IDE的JDK版本太高了
[/Quote]
我改试下
回复
soli11722984 2010-09-26
你的IDE的JDK环境和服务器的JDK环境版本不对吧

应该是IDE的JDK版本太高了
回复
youjianbo_han_87 2010-09-26
[Quote=引用 2 楼 qx8668 的回复:]

Java code
java.lang.UnsupportedClassVersionError: Bad version number in .class file

报这样的错误。
[/Quote]

JDK问题,重新编译下。。。
回复
qx8668 2010-09-26
java.lang.UnsupportedClassVersionError: Bad version number in .class file

报这样的错误。
回复
wuxiaoke2009 2010-09-26
也在学习中~~~
回复
相关推荐
发帖
Web 开发
创建于2007-09-28

8.0w+

社区成员

Java Web 开发
申请成为版主
帖子事件
创建了帖子
2010-09-26 02:36
社区公告
暂无公告