在debian上安装PHP时遇到的问题

lixuyuan 2011-01-18 10:48:46
配置的时候出现了这样的错误:
Configuring extensions
checking for OpenSSL support... yes
checking for Kerberos support... no
checking for pkg-config... /usr/bin/pkg-config
checking for OpenSSL version... >= 0.9.6
checking for CRYPTO_free in -lcrypto... yes
checking for SSL_CTX_set_ssl_version in -lssl... yes
checking for PCRE support... yes
checking for ZLIB support... yes
checking if the location of ZLIB install directory is defined... no
checking for gzgets in -lz... yes
checking whether to enable bc style precision math functions... no
checking for BZip2 support... no
checking whether to enable calendar conversion support... no
checking for cpdflib support... no
checking for CRACKlib support... no
checking whether to enable ctype functions... yes
checking for CURL support... yes
checking for CURL in default path... not found
configure: error: Please reinstall the libcurl distribution -
easy.h should be in <curl-dir>/include/curl/

然后我在网上找到一个解决办法:
#apt-get install curl
#apt-get install libcurl3
#apt-get install libcurl4-gnutls-dev

但是运行apt-get install libcurl4-gnutls-dev的时候又出现了错误:
# apt-get install libcurl4-gnutls-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
libcurl4-gnutls-dev: Depends: libcurl3-gnutls (= 7.18.2-8lenny4) but 7.19.5-1.1 is to be installed
Depends: libgnutls-dev but it is not going to be installed
Depends: libidn11-dev but it is not going to be installed
Depends: libkrb5-dev but it is not going to be installed or
hurd but it is not installable
Depends: libldap2-dev but it is not going to be installed
E: Broken packages
请问高手们这是怎么回事啊?
...全文
369 6 打赏 收藏 转发到动态 举报
写回复
用AI写文章
6 条回复
切换为时间正序
请发表友善的回复…
发表回复
shylqw 2012-06-28
  • 打赏
  • 举报
回复
怎么解决的啊?
lixuyuan 2011-01-19
  • 打赏
  • 举报
回复
谢谢大家,我的问题已经解决了,哈哈哈
ihefe 2011-01-18
  • 打赏
  • 举报
回复
安装程序最好找好他们的依赖包, 在一起安装这样不容易出错
ihefe 2011-01-18
  • 打赏
  • 举报
回复
少了这几个包

Depends: libcurl3-gnutls (= 7.18.2-8lenny4) but 7.19.5-1.1 is to be installed
Depends: libgnutls-dev but it is not going to be installed
Depends: libidn11-dev but it is not going to be installed
Depends: libkrb5-dev but it is not going to be installed or
hurd but it is not installable
Depends: libldap2-dev but it is not going to be installed

最好一起apt-get install
奇乐二二二 2011-01-18
  • 打赏
  • 举报
回复
直接在新立得里面装不就可以了 自己装还要配置php、mysql和apache之间的关联
skyaspnet 2011-01-18
  • 打赏
  • 举报
回复
最好是缺什么装什么,根据错误信息找到要安装的文件,执行 apt-get install 包名

即可

4,251

社区成员

发帖
与我相关
我的任务
社区描述
国内外优秀PHP框架讨论学习
社区管理员
  • Framework
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧