vs2008,宏关闭的时候,代码都变成灰色的了,我不想这样……

ciahi 2011-05-23 09:58:31
实际上宏我在别处定义了,但vs2008没有发现的话,就会被认为宏没有定义,然后把你的代码搞的一坨灰……

如何关闭这个功能呢? 谢谢!!!
...全文
430 点赞 收藏 12
写回复
12 条回复
suemiineo 2013年02月20日
去掉勾选 Tools | Options | Text Editor | C/C++ | Formatting | Colorize inactive code blocks in a different color google搜索关键字: vc disable inactive code gray 楼主你要感谢我的哦^^~!
回复 点赞
ciahi 2011年10月23日
没解决。。。
回复 点赞
土匪_泰哥 2011年10月16日
不知道楼主问题解决了,我感觉也是很不爽,希望有答案的指点一下,3q
回复 点赞
lifecode 2011年05月26日
既然这么难受,你就让vs2008知道你的宏吧。
回复 点赞
ciahi 2011年05月26日
因为宏在别处打开了,只是vs2008不能识别。。。

其实我的代码是会被编译执行的,但vs2008却自以为是,自认为这段代码应该是灰的。。。也没给个地方设置?
回复 点赞
hucailai 2011年05月24日
楼主的习惯比较特殊
回复 点赞
_free 2011年05月24日
我觉得挺好用的,灰色的直接跳过,干净利索
回复 点赞
ciahi 2011年05月24日
再顶一下

恶心的我快受不鸟了
回复 点赞
ciahi 2011年05月23日
请问楼上的,“显示项”的名字是什么?我找过几次都没找见,谢谢!
回复 点赞
kyotrue 2011年05月23日
options-environment-fonts and colors-Text editor
回复 点赞
ciahi 2011年05月23日
是呀,程序本身没影响,不过读代码的时候太恶心了

比如:
#ifdef MY_MACRO_DEF
mycode();
#endif

如果vs2008找不见MY_MACRO_DEF宏的话,就会把mycode()变成灰色的,而且这里面的代码全都是灰色!!!没一点高亮的效果了
回复 点赞
Eleven 2011年05月23日
预编译指令?#ifdef...#else...#endif ??
这个对你的程序有什么印象吗?
回复 点赞
发动态
发帖子
非技术类
创建于2007-09-28

1477

社区成员

5.9w+

社区内容

VC/MFC 非技术类
社区公告
暂无公告