关于XML element命名问题~

RoxPro 2011-06-22 04:46:16
大家好,我最近在做一个projet,要写一个XML文件,里面包含了多个conf文件的内容,我的目的就是用expat解析这个XML,然后生成多个conf文件,现在的问题是,我写的XML文件如下:
<?xml version="1.0" encoding="ISO-8859-1"?>
<note xmlns="RoxPro"
xmlns:xsi="C:/Users/RoxPro/My Documents/"
xsi:schemaLocation="RoxPro conf.xsd">

<conf>
<network>
<config interface loopback>

<option>
<ifname>lo</ifname>
<proto>static</proto>
<ipaddr>127.0.0.1</ipaddr>
<netmask>255.0.0.0</netmask>
</option>
</config interface loopback>
<config interface lan>

<option>
<ifname>eth0</ifname>
<type>bridge</type>
<proto>static</proto>
<ipaddr>192.168.1.1</ipaddr>
<netmask>255.255.255.0</netmask>
</option>
</config interface lan>
<config interface wifi>

<option>
<proto>static</proto>
<ipaddr>192.168.2.1</ipaddr>
<netmask>255.255.255.0</netmask>
</option>
</config interface wifi>
</network>

<wireless>
<config wifi-device radio0>

<option>
<type>atheros</type>
<channel>auto</channel>
<macaddr>00:15:6d:fc:71:ac</macaddr>
<disable>0</disable>
</option>
</config wifi-device radio0>

<config wifi-iface>
<option>
<device>radio0</device>
<network>wifi</network>
<mode>ap</mode>
<ssid>OpenWrt</ssid>
<encryption>none</encryption>
</option>
</config wifi-iface>
</wireless>
</conf>
</note>

我想解析这个XML文件并且生成2个文件分别叫network和wireless, network的内容如下:
config interface loopback
option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0

config interface lan
option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0

config interface wifi
option proto static
option ipaddr 192.168.2.1
option netmask 255.255.255.0


所以我想在element的命名里留空格,但是检查XML form的时候,编写的软件显示,这个element <config interface loopback>有错误,Missing equals sign between attribute and attribute value,请问如何解决这个问题?

PS:如果有哪位高人能再指导下expat的文件怎么写就更加感激不尽了~~
...全文
61 点赞 收藏 5
写回复
5 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
yang1216 2011-06-24
既然如此,就当它是字符串好了。
字符串解析随你咋搞。
只是它就不是XML了。
回复
cds27 2011-06-24
可以很明确的告诉你,如果你要使用XML,就必须按XML的规则来。
如果你想随心所欲,你完全可以不要用XML的解析器,靠自己来进行解析。就不会有这样的错误产生。

我们现在假定你必须用XML,那么你可以参考1楼提供的格式修改,并且,你可以不使用XSLT,仍然用你目前的解析器进行解析,所要做的就是,原来增加几句读取属性的代码就可以了,然后拼接字符串就可以了。
回复
ImN1 2011-06-24
这种情况最好用namespace
回复
RoxPro 2011-06-23
问题是我的工作范围是一个非常小的模块化的Linux,所以没有XSLT的支持...我能做的只有用一个C或者bash的parser去解析他,但是还是关于tags的回答~
回复
kalala2kalala 2011-06-23
XML 规范规定元素名是不能含有空格的,你含有空格,你的出错提示显示它把 config 视为元素名,interface 视为属性名了.
看你的 XML 结构,其实可以改成 <config interface="loopback">,<config interface="lan">,<config interface="wifi">,使用 xslt 可以很容易转为你想要的文本格式。
回复
相关推荐
发帖
智能路由器
创建于2018-06-15

636

社区成员

智能路由器通常具有独立的操作系统,包括OpenWRT、eCos、VxWorks等,可以由用户自行安装各种应用,实现网络和设备的智能化管理。
申请成为版主
帖子事件
创建了帖子
2011-06-22 04:46
社区公告
暂无公告