Myeclipse中快捷键没有提示???苦恼了好多天了,o(╯□╰)o

1988_1989 2011-07-15 11:26:46
在xml文件中也没有提示:例如在struts.xml中写<action name=""></action> 按alt+/组合键,name是不会提示出来的.

在class中,也是,syso按快捷键不会提示出System.out.println();

只有自定义了一个类和方法之后,再引用的时候是有提示的,

...全文
261 点赞 收藏 15
写回复
15 条回复
切换为时间正序
请发表友善的回复…
发表回复
1988_1989 2011-10-24
[Quote=引用 14 楼 ninige 的回复:]

你怎么解决的,我一样的问题 ,求解
[/Quote]

window-->preferences-->MyEclipse--->Files and Editors-->XML--->XML catelog
你看看第一行的struts-2.0.dtd的路径是不是打着一个小红叉,
如果是小红叉,那就是找不到次文件造成的,没有提示。

解决办法,将项目中的struts-2.0.dtd文件拷贝出来,放在D盘中,
window-->preferences-->MyEclipse--->Files and Editors-->XML--->XML catelog
选择http://struts.apacth.org/dtds/struts-2.0.dtd----点击右边的Edit,点击Location下的FlexSystem,,,,
选择D:\struts-2.0.dtd点击ok,
就好了。。。。

回复
ninige 2011-10-24
你怎么解决的,我一样的问题 ,求解
回复
1988_1989 2011-08-02
问题已解决。谢谢大家的踊跃提建议
回复
1988_1989 2011-07-18
[Quote=引用 11 楼 zuzhilong 的回复:]

你用的myeclipse版本是什么?8.0以上都支持struts2的智能提示,8.0以下的可以添加dtd文件链接提示。
[/Quote]

myeclipse 8.6

回复
HeiBoyYang 2011-07-15
1、启动MyEclipse 选择菜单栏 Windows ->Preperences ->General ->keys

2、把word completion 的快捷键设置alt+/删掉!//如果这里不删除的话,你就算设置了也没用的.

3、把Content Assist 的快捷键 改成alt+/


回复
贪睡的兔子 2011-07-15
自己设啊 搜索里打key ,自己设下content assist 注意快捷键
不要重复了
回复
这种情况多数为快捷键冲突了。
回复
window-preferences-general-editors-keys

里面检查一下。。
回复
zn85600301 2011-07-15
不会吧 不行你重新设置快捷键
回复
zuzhilong 2011-07-15
你用的myeclipse版本是什么?8.0以上都支持struts2的智能提示,8.0以下的可以添加dtd文件链接提示。
回复
1988_1989 2011-07-15
[Quote=引用 9 楼 wang153723482 的回复:]

不把快捷键设成alt+/试试呢。。。。。。
[/Quote]

试过了,我改成了其他的快捷键组合, 在keys中没有重复的快捷键哦,只有struts.xml这个配置文件中没有提示,其他的都有提示了...
回复
乌鸦不会飞 2011-07-15
不把快捷键设成alt+/试试呢。。。。。。
回复
1988_1989 2011-07-15
[Quote=引用 4 楼 dikeboy1234 的回复:]

自己设啊 搜索里打key ,自己设下content assist 注意快捷键
不要重复了
[/Quote]

没有重复的,我又检查了一下,

现在只有struts.xml中的快捷键提示不起作用,想web.xml和applicationContext.xml中都会有作用的,

搞不懂,我记得以前的struts.xml是可以使用快捷键提示的呀??
回复
1988_1989 2011-07-15
[Quote=引用 5 楼 heiboyyang 的回复:]

1、启动MyEclipse 选择菜单栏 Windows ->Preperences ->General ->keys

2、把word completion 的快捷键设置alt+/删掉!//如果这里不删除的话,你就算设置了也没用的.

3、把Content Assist 的快捷键 改成alt+/
[/Quote]


我的做法是: Windows ->Preperences ->General ->keys
显示的窗口中单击右下角restore Defaults,类中的提示就可以出现了,

但是xml文件中的提示还是没有啊,,,,,o(╯□╰)o
回复
desk11 2011-07-15
寻找了很多天,也不知道用法
回复
发动态
发帖子
Eclipse
创建于2007-09-28

5.8w+

社区成员

Java Eclipse
申请成为版主
社区公告
暂无公告