社区
MySQL
帖子详情
mysql 主从数据库
byeceg
2011-09-01 04:52:25
配置好了主从数据库,日志也没报什么错。
当主库发生改变后(修改,删除),
主 show master status \G
从 show slave status \G
主库和从库的日志文件,位置Position,都会发生改变。
但问题是,从库的数据并没有改变。主库中删除的数据还在。
是什么问题?
...全文
111
6
打赏
收藏
mysql 主从数据库
配置好了主从数据库,日志也没报什么错。 当主库发生改变后(修改,删除), 主 show master status \G 从 show slave status \G 主库和从库的日志文件,位置Position,都会发生改变。 但问题是,从库的数据并没有改变。主库中删除的数据还在。 是什么问题?
复制链接
扫一扫
分享
举报
写回复
配置赞助广告
用AI写文章
6 条
回复
切换为时间正序
请发表友善的回复…
发表回复
打赏红包
byeceg
2011-09-02
打赏
举报
回复
[Quote=引用 5 楼 rucypli 的回复:]
RESET SLAVE
用于让从属服务器忘记其在主服务器的二进制日志中的复制位置。本语句被用于进行一个明确的启动:它会删除master.info和relay-log.info文件,以及所有的中继日志,并启动一个新的中继日志。
注释:所有的中继日志被删除,即使它们没有被从属服务器SQL线程完全的执行。(如果您已经发布了一个SLAVE语句或如果从属服务器的载入量很大,则这对于一个复制从属服务……
[/Quote]
谢谢
rucypli
2011-09-01
打赏
举报
回复
RESET SLAVE
用于让从属服务器忘记其在主服务器的二进制日志中的复制位置。本语句被用于进行一个明确的启动:它会删除master.info和relay-log.info文件,以及所有的中继日志,并启动一个新的中继日志。
注释:所有的中继日志被删除,即使它们没有被从属服务器SQL线程完全的执行。(如果您已经发布了一个SLAVE语句或如果从属服务器的载入量很大,则这对于一个复制从属服务器是一个很可能出现的情况。)
存储在master.info文件中的连接信息通过使用在对应的启动选项中指定的值,被立即重新设置了。此信息包括主服务器主机、主服务器接口、主服务器用户和主服务器 密码等值。当从属服务器SQL线程被中止时,它位于正在复制的临时表的中间,并且发布了RESET SLAVE,则已被复制的临时表在从属服务器中被删除。
byeceg
2011-09-01
打赏
举报
回复
解决了,谁能给解释下。
之前,slave stop;slave start;都不能同步
reset slave;用这个,居然好了。
byeceg
2011-09-01
打赏
举报
回复
show master status \G
*************************** 1. row ***************************
File: mysql-bin.000013
Position: 48183
Binlog_Do_DB: xxxxxx
Binlog_Ignore_DB: mysql
1 row in set (0.00 sec)
byeceg
2011-09-01
打赏
举报
回复
Slave_IO_State: Waiting for master to send event
Master_Host: xxxx
Master_User: xxxx
Master_Port: 3306
Connect_Retry: 60
Master_Log_File: mysql-bin.000013
Read_Master_Log_Pos: 48183
Relay_Log_File: database-relay-bin.000001
Relay_Log_Pos: 4
Relay_Master_Log_File:
Slave_IO_Running: Yes
Slave_SQL_Running: Yes
Replicate_Do_DB: xxxxxx
Replicate_Ignore_DB:
Replicate_Do_Table:
Replicate_Ignore_Table:
Replicate_Wild_Do_Table:
Replicate_Wild_Ignore_Table:
Last_Errno: 0
Last_Error:
Skip_Counter: 0
Exec_Master_Log_Pos: 0
Relay_Log_Space: 213156705
Until_Condition: None
Until_Log_File:
Until_Log_Pos: 0
Master_SSL_Allowed: No
Master_SSL_CA_File:
Master_SSL_CA_Path:
Master_SSL_Cert:
Master_SSL_Cipher:
Master_SSL_Key:
Seconds_Behind_Master: 0
Master_SSL_Verify_Server_Cert: No
Last_IO_Errno: 0
Last_IO_Error:
Last_SQL_Errno: 0
Last_SQL_Error:
1 row in set (0.00 sec)
不知道哪不对?日志也没报错.
rucypli
2011-09-01
打赏
举报
回复
你肯定看错了,如果show slave status没报错的话 或者没有延迟的话
mysql
主从
字符集不一致,
mysql
主从
数据库
同步和字符集问题
mysql
主从
数据库
同步和字符集问题1.
mysql
主从
数据库
同步问题在使用
mysql
5.0
主从
数据库
同步时遇到问题一些问题:在
主从
数据库
同步时,我们可能会选择哪些
数据库
要求同步,而那些
数据库
忽视,这两个功能是靠/etc/my.cnf文件中的两个键名 binlog_do_db 和 binlog_ignore_db 来实现的binlog_do_db = 填写需要同步的
数据库
,多个
数据库
则用‘,’隔...
MySQL
之——
主从
复制时主库和备库的
数据库
名称不一致怎么办?
问题: 在常规的
MySQL
主从
复制架构中,主库和备库的
数据库
时完全一样的,如果主库和备库的
数据库
名称不一样怎么办? 比如:主库的
数据库
名称为binghe_master, 从库的
数据库
名称为binghe_slave,则按照常规方式配置好
主从
复制后,要如何处理呢? 解决方案: 在按照常规方式配置好
MySQL
主从
复制之后,我们可以使用CHANGE REPLICATION FILTER语句将主库和从...
MySQL
数据库
主从
配置
(创建非空表并创建name和addr两个列),最后insert into company values(1,"shenyang","china"),在表中添加shenyang china。在master节点授权任何客户端可以用root用户登录到
数据库
,然后在master创建一个user用户连接slave,并赋予其在slave节点同步数据的权限。(2)
Mysql
主从
服务:在A上写入数据,B也会跟着写数据,两者同步,
mysql
主从
复制是一种
数据库
复制技术。(3)在slave节点查看
数据库
的内容。
mysql
主从
复制不生效_
mysql
主从
复制 replicate-rewrite-db 无效
主库配置:log-bin=
mysql
-binserver-id = 66从库配置:server-id = 67replicate-do-db = liuxm_testreplicate-rewrite-db = liuxm_test->liuxm同步无效,但是把replicate-rewrite-db去掉,在从库上建一个liuxm_test库就可以同步求大神指点
mysql
> show ...
mysql
replicate-rewrite-db,
mysql
主从
复制 replicate-rewrite-db 无效
主库配置:log-bin=
mysql
-binserver-id = 66从库配置:server-id = 67replicate-do-db = liuxm_testreplicate-rewrite-db = liuxm_test->liuxm同步无效,但是把replicate-rewrite-db去掉,在从库上建一个liuxm_test库就可以同步求大神指点
mysql
> show ...
MySQL
57,062
社区成员
56,759
社区内容
发帖
与我相关
我的任务
MySQL
MySQL相关内容讨论专区
复制链接
扫一扫
分享
社区描述
MySQL相关内容讨论专区
社区管理员
加入社区
获取链接或二维码
近7日
近30日
至今
加载中
查看更多榜单
社区公告
暂无公告
试试用AI创作助手写篇文章吧
+ 用AI写文章