zend studio xdebug 57% waiting for xdebug session

风.foxwho 2011-11-20 03:52:50
问题说明:
防火墙全关。phpinfo();中都有xdebug.在 netbeans 软件调试中,都正常,可以调试。百度,GOOGLE搜了没找到原因

zend studio 中,调试xdebug错误
57%
waiting for xdebug session

一直是57%
------------
操作系统 win7 64
环境:
PHP 5.3.8 VC9
Apache 2.2.19 VC9
MySQL 5.5.15
PhpMyAdmin 3.4.3.2
Xdebug 2.1.2


以下是php.ini配置

;Xdebug
zend_extension = "e:\EasyPHP-5.3.8.0\xdebug\php_xdebug-2.1.2-5.3-vc9.dll"
xdebug.default_enable=0
xdebug.remote_enable=true
xdebug.remote_host=127.0.0.1
xdebug.remote_port=29001
xdebug.remote_handler=dbgp
xdebug.remote_mode=req
xdebug.remote_autostart =false
xdebug.dump_globals=1
xdebug.dump=COOKIE,FILES,GET,POST,REQUEST,SERVER,SESSION
xdebug.dump.SERVER=REMOTE_ADDR,REQUEST_METHOD,REQUEST_URI
xdebug.max_nesting_level = 10000
xdebug.show_local_vars=1
xdebug.show_mem_delta=1
xdebug.collect_includes=1
xdebug.collect_vars=1
xdebug.collect_params=4
xdebug.collect_return=1
xdebug.auto_trace=0
xdebug.trace_options=0
xdebug.trace_format=0
xdebug.trace_output_dir="E:\EasyPHP-5.3.8.0\xdebug\trace"
xdebug.trace_output_name="trace.%t"
xdebug.profiler_enable=0
xdebug.profiler_append=1
xdebug.profiler_enable_trigger=1
xdebug.profiler_output_dir="E:\EasyPHP-5.3.8.0\xdebug\profiler"
xdebug.profiler_output_name="cachegrind.out.%s.%t"
;/Xdebug
...全文
540 点赞 收藏 3
写回复
3 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
wf1768 2012-09-09
csdn 真尼玛垃圾,看个回复还要登录。登录后就看到正确答案竟然是“重新设置调试环境 我忘记是怎么解决了,试过这样的事情。”,我日你
回复
hehu158 2012-05-06
楼主卸载多余的apache就可以了啊,今天我也遇到了,我本机装了apache还有wamp,结果跟楼主的情况一样,卸载了多余的apache重新调试,结果就可以了啊。
回复
黄袍披身 2011-11-20
重新设置调试环境 我忘记是怎么解决了,试过这样的事情。
回复
相关推荐
发帖
基础编程
创建于2007-09-28

2.1w+

社区成员

从PHP安装配置,PHP入门,PHP基础到PHP应用
申请成为版主
帖子事件
创建了帖子
2011-11-20 03:52
社区公告
暂无公告