我用kill4给stm32的板子烧程序的时候出现问题

xiaoLqiF 2011-12-16 07:04:44
显示No Crotex-M Device found in JTAG chain
上次烧的的时候还是好的啊。。。
在这次烧纸钱,我给板子接了近6.5V的电压,有点冒烟了,但是我看着没有哪里坏掉了
然后显示的是这个
* JLink Info: Could not measure total IR len. TDO is constant high.
**JLink Warning: No matching core found. Selecting default core (ARM7).
* JLink Info: Could not measure total IR len. TDO is constant high.
* JLink Info: Could not measure total IR len. TDO is constant high.
* JLink Info: Resetting target using RESET pin
* JLink Info: Halting CPU core
**JLink Warning: Received 0 as core Id.
* JLink Info: Using DBGRQ to halt CPU
* JLink Info: Resetting TRST in order to halt CPU
* JLink Info: Resetting target using RESET pin
* JLink Info: Halting CPU core
**JLink Warning: Received 0 as core Id.
* JLink Info: Using DBGRQ to halt CPU
* JLink Info: Resetting TRST in order to halt CPU
***JLink Error: Could not find supported CPU core on JTAG chain
Bad JTAG communication: Write to IR: Expected 0x1, got 0x0 (TAP Command : 2) @ Off 0x5.
Unable to halt ARM core
**JLink Warning: Target system has been power-cycled
* JLink Info: TotalIRLen = ?, IRPrint = 0x..000000000000000000000000
**JLink Warning: No matching core found. Selecting default core (ARM7).
* JLink Info: TotalIRLen = ?, IRPrint = 0x..000000000000000000000000
***JLink Error: Could not find supported CPU core on JTAG chain
到底是哪里出了问题啊,我在网上搜的说什么boot拉高位什么的。。。
我现在完全不懂arm啊。。。
哪位大神指导下啊。。。
...全文
4107 7 打赏 收藏 举报
写回复
7 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
左击 2014-09-04
debug/setting/sw口 OKOK
  • 打赏
  • 举报
回复
Shawn4com 2013-03-05
楼主试试启动更改方式,boot0接VCC试试,我的出现这种情况,更改启动方式好了。。
  • 打赏
  • 举报
回复
Simality 2012-03-02
你把Jlink从板子上完全断开,然后测试,如果提示的错误信息还是那样就说明Jlink到目标板之间的连接完全没起作用。这时候可能板子坏了,也可能Jlink里头的那片电平转换芯片有一侧坏了,也可能二者都坏了。这个情况下最快的方式是换Jlink或者换目标板测试,根据现象变化来判断哪里出了问题,然后逐一修复。
  • 打赏
  • 举报
回复
jobszheng5 2012-03-02
同情一下吧。
我估计是jlink换掉了,楼主买得应该是D版的jlink吧。
那个D版的很容易烧坏的。一次不小心的带电插拔就可能将其烧坏~~
  • 打赏
  • 举报
回复
lbing7 2012-03-02
不能下载,通常是连接问题

如果连接没问题,换完仿真器不行再换芯片

:)
  • 打赏
  • 举报
回复
cos_sin_tan 2012-03-01
要在utility里面添加一个东西
  • 打赏
  • 举报
回复
Binzo 2011-12-16
没上电是也会说:
No matching core found.

估计板子出问题了,找个厉害的人帮你看看吧。
  • 打赏
  • 举报
回复
相关推荐
发帖
单片机/工控
加入

2.6w+

社区成员

硬件/嵌入开发 单片机/工控
申请成为版主
帖子事件
创建了帖子
2011-12-16 07:04
社区公告
暂无公告