关于给HBITMAP数组赋值的问题,请教高手!!!!

xml细尾 2012-01-09 05:31:25
代码如下:
HBITMAP *hbmp = new HBITMAP[20];
hbmp[0] = SHLoadDIBitmap(_T("\\a.bmp")); /*报错,binary '=' : no operator found which takes a right-hand operand of type 'HBITMAP' (or there is no acceptable conversion)*/

HBITMAP hbmp1;
hbmp1 = SHLoadDIBitmap(_T("\\a.bmp"));//这样是没有错的


问题:如何给HBITMAP类型的数组赋值呢?
...全文
91 点赞 收藏 9
写回复
9 条回复
xml细尾 2012年01月13日
[Quote=引用 4 楼 gameslq 的回复:]

C/C++ code
HBITMAP *hbmp = new HBITMAP[20];
hbmp[0] = SHLoadDIBitmap(_T("\\a.bmp"));
改为
HBITMAP hbmp[20];
hbmp[0] = SHLoadDIBitmap(_T("\\a.bmp"));
是否还报错?
[/Quote]

你说的这个方法我一开始就是这么做的,报同样的错哦,不得其解……
回复 点赞
xml细尾 2012年01月13日
[Quote=引用 3 楼 xianglitian 的回复:]

你做的是winCE的程序?
[/Quote]
是的,我是在wince6.0下用SDK做的,不知有何区别?

回复 点赞
xml细尾 2012年01月13日
[Quote=引用 2 楼 gis_wudi 的回复:]

HBITMAP *hbmp = new HBITMAP[20];
hbmp[0] = SHLoadDIBitmap(_T("a.bmp"));
返回值是这样赋值没有问题
如果还出错,建议用LoadBitmap
[/Quote]

GIS_wudi:因为必需要用到SHLoadDIBitmap()这个函数,单个变量赋没问题,改成数组就不行了……

回复 点赞
xml细尾 2012年01月13日
[Quote=引用 8 楼 xianglitian 的回复:]

引用 6 楼 xm877 的回复:
引用 3 楼 xianglitian 的回复:

你做的是winCE的程序?

是的,我是在wince6.0下用SDK做的,不知有何区别?

我用你的代码试了一下
没有任何问题
我这面的环境是VS2005+WinCE5.0
[/Quote]


额额,确实没问题,怎么说呢
我定义的全局变量hbmp[20]和很久以前测试定义的成员变量hbmp重名了
纠结了几天,原来是个乌龙……
结帖了,N个谢谢……


回复 点赞
向立天 2012年01月13日
[Quote=引用 6 楼 xm877 的回复:]
引用 3 楼 xianglitian 的回复:

你做的是winCE的程序?

是的,我是在wince6.0下用SDK做的,不知有何区别?
[/Quote]
我用你的代码试了一下
没有任何问题
我这面的环境是VS2005+WinCE5.0
回复 点赞
gameslq 2012年01月12日
HBITMAP *hbmp = new HBITMAP[20];
hbmp[0] = SHLoadDIBitmap(_T("\\a.bmp"));
改为
HBITMAP hbmp[20];
hbmp[0] = SHLoadDIBitmap(_T("\\a.bmp"));
是否还报错?
回复 点赞
向立天 2012年01月12日
你做的是winCE的程序?
回复 点赞
GIS_wudi 2012年01月12日
HBITMAP *hbmp = new HBITMAP[20];
hbmp[0] = SHLoadDIBitmap(_T("a.bmp"));
返回值是这样赋值没有问题
如果还出错,建议用LoadBitmap
回复 点赞
xml细尾 2012年01月12日
没人理6
回复 点赞
发动态
发帖子
VC/MFC
创建于2007-09-28

7890

社区成员

42.1w+

社区内容

VC/MFC相关问题讨论
社区公告
暂无公告