求助,一道贪心的题。。。

SmallKind 2012-05-23 12:29:25
Wooden Sticks
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5719 Accepted Submission(s): 2359


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l' and weight w' if l<=l' and w<=w'. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).



Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.



Output
The output should contain the minimum setup time in minutes, one per line.



Sample Input
3
5
4 9 5 2 2 1 3 5 1 4
3
2 2 1 1 2 2
3
1 3 2 2 3 1


Sample Output
2
1
3
#include<iostream>
using namespace std;
int main()
{
int t,n,i,j,x,y,num;
int a[5005],b[5005];
cin>>t;
while(t--)
{
cin>>n;
for(i=0;i<n;i++)
cin>>a[i]>>b[i];
for(i=0;i<n;i++)
for(j=0;j<n-1-i;j++)
if(a[j]>a[j+1])
{
x=a[j+1];
a[j+1]=a[j];
a[j]=x;
y=b[j+1];
b[j+1]=b[j];
b[j]=y;
}
for(i=0;i<n;i++)
for(j=0;j<n-1-i;j++)
if(b[j]>b[j+1])
{
y=b[j+1];
b[j+1]=b[j];
b[j]=y;
x=a[j+1];
a[j+1]=a[j];
a[j]=x;
}
num=1;
for(i=0;i<n-1;i++)
if(a[i+1]<a[i]||b[i+1]<b[i])
num++;
cout<<num<<endl;
}
return 0;
}
这是我的代码,请问哪里错啦,上面的测试数据我的代码都可以过,求给几组测试数据。。。求大牛的解题思路啊,谢谢啦。。
...全文
124 2 打赏 收藏 转发到动态 举报
写回复
用AI写文章
2 条回复
切换为时间正序
请发表友善的回复…
发表回复
SmallKind 2012-05-23
  • 打赏
  • 举报
回复
[Quote=引用 1 楼 的回复:]
这个基数排序(桶排序)确实能够解决问题
[/Quote]
但哪里错啦,提交时是错误的啊,A不过啊。。。
powerW 2012-05-23
  • 打赏
  • 举报
回复
这个基数排序(桶排序)确实能够解决问题

64,650

社区成员

发帖
与我相关
我的任务
社区描述
C++ 语言相关问题讨论,技术干货分享,前沿动态等
c++ 技术论坛(原bbs)
社区管理员
  • C++ 语言社区
  • encoderlee
  • paschen
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
  1. 请不要发布与C++技术无关的贴子
  2. 请不要发布与技术无关的招聘、广告的帖子
  3. 请尽可能的描述清楚你的问题,如果涉及到代码请尽可能的格式化一下

试试用AI创作助手写篇文章吧