Eclipse Juno Service Release 1版本如何配置Hibernate

chaoliu1024 2013-01-27 05:57:16
用eclipse如何配置Hibernate
我的eclipse版本是 elispse jee Juno Service Release 1
这样安装插件JBossTool - http://download.jboss.org/jbosstools/updates/stable/helios/报版本有冲突的错误。
如上图

错误如下:
Cannot complete the install because of a conflicting dependency.
Software being installed: Hibernate Tools 3.4.0.v20111025-0625-H210-Final (org.hibernate.eclipse.feature.feature.group 3.4.0.v20111025-0625-H210-Final)
Software currently installed: Eclipse IDE for Java EE Developers 1.5.1.20120917-1257 (epp.package.jee 1.5.1.20120917-1257)
Only one of the following can be installed at once:
Structured Source Editor 1.2.5.v201108191505 (org.eclipse.wst.sse.ui 1.2.5.v201108191505)
Structured Source Editor 1.3.101.v201208170345 (org.eclipse.wst.sse.ui 1.3.101.v201208170345)
Structured Source Editor 1.3.100.v201204260100 (org.eclipse.wst.sse.ui 1.3.100.v201204260100)
Only one of the following can be installed at once:
Structured Source XML Model 1.1.700.v201204241737 (org.eclipse.wst.xml.core 1.1.700.v201204241737)
Structured Source XML Model 1.1.505.v201106091951 (org.eclipse.wst.xml.core 1.1.505.v201106091951)
Cannot satisfy dependency:
From: Eclipse IDE for Java EE Developers 1.5.1.20120917-1257 (epp.package.jee 1.5.1.20120917-1257)
To: org.eclipse.epp.package.jee.feature.feature.group [1.5.1.20120917-1257]
Cannot satisfy dependency:
From: Java EE IDE Feature 1.5.1.20120917-1257 (org.eclipse.epp.package.jee.feature.feature.group 1.5.1.20120917-1257)
To: org.eclipse.jpt.common.eclipselink.feature.feature.group 0.0.0
Cannot satisfy dependency:
From: Java EE IDE Feature 1.5.1.20120917-1257 (org.eclipse.epp.package.jee.feature.feature.group 1.5.1.20120917-1257)
To: org.eclipse.wst.xml_ui.feature.feature.group 0.0.0
Cannot satisfy dependency:
From: Dali Java Persistence Tools - Common EclipseLink Core 1.2.0.v201203150000 (org.eclipse.jpt.common.eclipselink.core 1.2.0.v201203150000)
To: bundle org.eclipse.wst.xml.core [1.1.600,2.0.0)
Cannot satisfy dependency:
From: Dali Java Persistence Tools - Common EclipseLink Core 1.2.1.v201208222210 (org.eclipse.jpt.common.eclipselink.core 1.2.1.v201208222210)
To: bundle org.eclipse.wst.xml.core [1.1.600,2.0.0)
Cannot satisfy dependency:
From: Dali Java Persistence Tools - EclipseLink Common 1.2.0.v201203150000-33-8s7357395D3333 (org.eclipse.jpt.common.eclipselink.feature.feature.group 1.2.0.v201203150000-33-8s7357395D3333)
To: org.eclipse.jpt.common.eclipselink.core [1.2.0.v201203150000]
Cannot satisfy dependency:
From: Dali Java Persistence Tools - EclipseLink Common 1.2.1.v201208222210-3318s73573J777753 (org.eclipse.jpt.common.eclipselink.feature.feature.group 1.2.1.v201208222210-3318s73573J777753)
To: org.eclipse.jpt.common.eclipselink.core [1.2.1.v201208222210]
Cannot satisfy dependency:
From: Dali Java Persistence Tools - UI 2.3.2.v201008252310 (org.eclipse.jpt.ui 2.3.2.v201008252310)
To: bundle org.eclipse.wst.sse.ui [1.1.0,1.3.0)
Cannot satisfy dependency:
From: WST XML Core 3.2.5.v201106160200-7C7OFXjF7RZHQLJ2MBN7XY (org.eclipse.wst.xml_core.feature.feature.group 3.2.5.v201106160200-7C7OFXjF7RZHQLJ2MBN7XY)
To: org.eclipse.wst.xml.core [1.1.505.v201106091951]
Cannot satisfy dependency:
From: Eclipse XML Editors and Tools 3.2.5.v201106160200-7H7AFUeDxumQJP58ph_R_6rz0oA8uNCN3V3QuPL (org.eclipse.wst.xml_ui.feature.feature.group 3.2.5.v201106160200-7H7AFUeDxumQJP58ph_R_6rz0oA8uNCN3V3QuPL)
To: org.eclipse.wst.xml_core.feature.feature.group [3.2.5.v201106160200-7C7OFXjF7RZHQLJ2MBN7XY]
Cannot satisfy dependency:
From: Eclipse XML Editors and Tools 3.4.0.v201111021744-7H7GFeBDxumUpsl5liePhK3loz-m62J4rSz011R1 (org.eclipse.wst.xml_ui.feature.feature.group 3.4.0.v201111021744-7H7GFeBDxumUpsl5liePhK3loz-m62J4rSz011R1)
To: org.eclipse.wst.sse.ui [1.3.100.v201204260100]
Cannot satisfy dependency:
From: Eclipse XML Editors and Tools 3.4.1.v201208170345-7H7GFeFDxumUpsw5rgjWnKDrsz0p4ymwjQz00T2S (org.eclipse.wst.xml_ui.feature.feature.group 3.4.1.v201208170345-7H7GFeFDxumUpsw5rgjWnKDrsz0p4ymwjQz00T2S)
To: org.eclipse.wst.sse.ui [1.3.101.v201208170345]
Cannot satisfy dependency:
From: Hibernate Tools 3.4.0.v20111025-0625-H210-Final (org.hibernate.eclipse.feature.feature.group 3.4.0.v20111025-0625-H210-Final)
To: org.jboss.tools.hibernate.jpt.ui [3.4.1.v20111025-0625-H210-Final]
Cannot satisfy dependency:
From: Hibernate Jdt UI 3.4.1.v20111025-0625-H210-Final (org.jboss.tools.hibernate.jpt.ui 3.4.1.v20111025-0625-H210-Final)
To: bundle org.eclipse.jpt.ui 0.0.0
请入如何安装?

不用myEclipse是因为机器比较慢,跑不动!
...全文
222 3 点赞 打赏 收藏 举报
写回复
3 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
jackycaia 2013-08-05
这个url貌似可以哦 http://download.jboss.org/jbosside/updates/stable
  • 打赏
  • 举报
回复
chaoliu1024 2013-07-07
好吧,没有人么?
  • 打赏
  • 举报
回复
dingyingsi 2013-01-28
你到JBoss网站上找和你的Eclipse对应的在线安装网址进行安装,Eclipse版本和持久化工具版本不一致,不一定能装上. Juno,helios应该不一样吧。
  • 打赏
  • 举报
回复
相关推荐
发帖
Java EE
加入

6.7w+

社区成员

J2EE只是Java企业应用。我们需要一个跨J2SE/WEB/EJB的微容器,保护我们的业务核心组件(中间件),以延续它的生命力,而不是依赖J2SE/J2EE版本。
申请成为版主
帖子事件
创建了帖子
2013-01-27 05:57
社区公告
暂无公告