Qt 在 Windows 上为什么没有 64 位的?

Jonix 2013-02-17 12:43:55
Qt 在 Windows 上为什么没有 64 位的?

什么时候能有呢??
...全文
22317 24 点赞 打赏 收藏 举报
写回复
24 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
从来不作 2015-05-22
引用 23 楼 cm4220 的回复:
[quote=引用 22 楼 banshichiqinglangzi 的回复:] 帖子很老了,方便下后来人。qt 64bit http://sourceforge.net/projects/qtx64/
这个链接里面的文件没有了[/quote] 其他链接:http://tver-soft.org/qt64 http://sourceforge.net/projects/qt64ng/
  • 打赏
  • 举报
回复
cm4220 2015-05-22
引用 22 楼 banshichiqinglangzi 的回复:
帖子很老了,方便下后来人。qt 64bit http://sourceforge.net/projects/qtx64/
这个链接里面的文件没有了
  • 打赏
  • 举报
回复
从来不作 2015-05-11
帖子很老了,方便下后来人。qt 64bit http://sourceforge.net/projects/qtx64/
  • 打赏
  • 举报
回复
liang121711 2013-12-23
引用 14 楼 Jonix 的回复:
网上有一个编译好的,我照他的方式也能编译出来: http://pan.baidu.com/share/link?shareid=216392&uk=3842042263 望楼上能提供一个详细的配置教程分享大家,万分感谢 。
现在打不开了,能不能分享一个
  • 打赏
  • 举报
回复
引用 19 楼 Jonix 的回复:
能搞个Step by Step给大家一起分享分享吗?
我没用过MSVC的Qt, 所以很抱歉, 我也Step不出来. 不过也不会很困难, 自己编译当然是最好, Compiler Compatibility是完全的, 如果要用别人的预编译版, 就一定要保证编译器版本. 理论上来说, 把预编译版的Qt装好了以后, 按照我上文说的三个选项设置Qt Creator的Kit就可以了. 你用的是那个版的MSVC?
  • 打赏
  • 举报
回复
Jonix 2013-02-21
引用 16 楼 allencui0313 的回复:
弱弱的问一下 。debug不慢么?
不慢,挺快的。
  • 打赏
  • 举报
回复
Jonix 2013-02-21
引用 18 楼 HeadmasterWang 的回复:
引用 14 楼 Jonix 的回复:网上有一个编译好的,我照他的方式也能编译出来: http://pan.baidu.com/share/link?shareid=216392&uk=3842042263 望楼上能提供一个详细的配置教程分享大家,万分感谢 。 预编译版本的编译器必须和你用的编译器是同一版. Compiler那一项选目标编译预……
能搞个Step by Step给大家一起分享分享吗?
  • 打赏
  • 举报
回复
弱弱的问一下 。debug不慢么?
  • 打赏
  • 举报
回复
没注意。不过我昨晚安装qtcreator的时候会提示出错,但忽略过去也可以使用。
  • 打赏
  • 举报
回复
Jonix 2013-02-21
网上有一个编译好的,我照他的方式也能编译出来: http://pan.baidu.com/share/link?shareid=216392&uk=3842042263 望楼上能提供一个详细的配置教程分享大家,万分感谢 。
  • 打赏
  • 举报
回复
引用 14 楼 Jonix 的回复:
网上有一个编译好的,我照他的方式也能编译出来: http://pan.baidu.com/share/link?shareid=216392&uk=3842042263 望楼上能提供一个详细的配置教程分享大家,万分感谢 。
预编译版本的编译器必须和你用的编译器是同一版. Compiler那一项选目标编译预编译版的也就是你用的编译器 Debugger找CDB Qt Version找预编译版目录里面的qmake
  • 打赏
  • 举报
回复
  • 打赏
  • 举报
回复
引用 10 楼 Jonix 的回复:
我喜欢用 Qt Creator ,但是编译器必须是 VC
Qt Creator 可以用VS的Tool Chain的
  • 打赏
  • 举报
回复
一定要用VS吗? Qt Creator就挺好的, 原生支持, 而且还跨平台. 比VS启动要 Qt对VS的支持不是多么的好
  • 打赏
  • 举报
回复
Jonix 2013-02-20
引用 7 楼 HeadmasterWang 的回复:
QtSDK带的版本是4.8还有4.7, 可以先装SDK, 再装5.0.1-open-source. 要注意的是SDK的QtCreator版本有点低, 让5.0.1的包覆盖一下就好了. SDK一定有Perl, 5.0.1的包我就不清楚了
确认了,是不带perl的,需要自行安装的。 我搞定了,能编译了。 但是不知道在 msvc 中怎么使用,装了 add-in ,不认 64位的 Qt库
  • 打赏
  • 举报
回复
QtSDK带的版本是4.8还有4.7, 可以先装SDK, 再装5.0.1-open-source. 要注意的是SDK的QtCreator版本有点低, 让5.0.1的包覆盖一下就好了. SDK一定有Perl, 5.0.1的包我就不清楚了
  • 打赏
  • 举报
回复
Jonix 2013-02-20
引用 5 楼 HeadmasterWang 的回复:
QtSDK带Perl. 带的MinGW也有64的ABI
请教 Perl 在哪个目录下? 我用的是 Qt5.0 for vc2010 正式版
  • 打赏
  • 举报
回复
sduxiaoxiang 2013-02-20
自己编译个64bit就是 只是没有和vs的集成器,使用麻烦点 32bit生成的moc文件直接拷贝过去就可以用了
  • 打赏
  • 举报
回复
Jonix 2013-02-20
我喜欢用 Qt Creator ,但是编译器必须是 VC
  • 打赏
  • 举报
回复
QtSDK带Perl. 带的MinGW也有64的ABI
  • 打赏
  • 举报
回复
加载更多回复
相关推荐
发帖
Qt
加入

1.3w+

社区成员

Qt 是一个跨平台应用程序框架。通过使用 Qt,您可以一次性开发应用程序和用户界面,然后将其部署到多个桌面和嵌入式操作系统,而无需重复编写源代码。
申请成为版主
帖子事件
创建了帖子
2013-02-17 12:43
社区公告
暂无公告