导航
  • 主页
  • 系统维护与使用
  • 应用程序开发
  • 内核源代码
  • 驱动程序开发
  • CPU和硬件区
  • UNIX文化
  • Solaris
  • Power Linux
  • 问答

Ubuntu12.04 64位 系统安装安装 db2_v1012_linuxx64_expc.tar.gz出错了??

1988_1989 2013-04-28 05:16:10
用SSH上传到UbunTu中,然后解压db2_v1012_linuxx64_expc.tar.gz
接下来进行如下的命令:

root@ubuntu:~# cd expc
root@ubuntu:~/expc# ./db2_install
ERROR:
The 'strings' utility that is used to detect prerequisite libraries
is not present on this system. Please use your package or software
manager to install the GNU Binary Utilities.
Requirement not matched for DB2 database "Server" "". Version: "10.1.0.2".
Summary of prerequisites that are not met on the current system:
DBT3514W The db2prereqcheck utility failed to find the following 32-bit library file: "/lib/libpam.so*".


DBI1324W Support of the db2_install command is deprecated. For
more information, see the DB2 Information Center.


Aborting the current installation ...
Run installation with the option "-f sysreq" parameter to force the installation.
root@ubuntu:~/expc#


哪位高手帮忙解决一下,
我又下载了32位的DB2,安装,还是有错误啊,,到底是哪里的问题》》
...全文
307 点赞 收藏 4
写回复
4 条回复
切换为时间正序
请发表友善的回复…
发表回复
1988_1989 2013-05-30
引用 2 楼 linwhwylb 的回复:
先安装这个strings工具吧。 The 'strings' utility that is used to detect prerequisite libraries
楼上说的很正确。 具体解决方案,http://db365.net/forum.php?mod=viewthread&tid=1560&extra=page%3D1
回复
zaixiankaifa 2013-04-29
我装了的话没问题
回复
Linux-Torvalds 2013-04-28
先安装这个strings工具吧。 The 'strings' utility that is used to detect prerequisite libraries
回复
prohibit 2013-04-28
The db2prereqcheck utility failed to find the following 32-bit library file: "/lib/libpam.so*". Run installation with the option "-f sysreq" parameter to force the installation. 这两句提示你看看呢
回复
发动态
发帖子
Linux/Unix社区
创建于2007-08-27

2.0w+

社区成员

Linux/Unix社区 应用程序开发区
申请成为版主
社区公告
暂无公告