acm题,请大家多多帮忙,谢谢了

heartzhizi 2013-04-30 11:18:17
The Triangle
时间限制:1000 ms | 内存限制:65535 KB
难度:4
描述
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入
Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.
输出
Your program is to write to standard output. The highest sum is written as an integer.
样例输入
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
样例输出
30
题的描述如上,我的代码如下,为什么总是不对,我是从上往下计算的,谢谢哈
动态方程 num[i][j]=max{num[i-1][j],num[i-1][j-1]}+a[i][j];



#include<stdio.h>
int main()
{
int a[101][101],num[101][101],n,i,j,max;


scanf("%d",&n);
for(i=0;i<=n;i++)
for(j=0;j<=i;j++)
{
a[i][j]=0;
num[i][j]=0;
}
for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
scanf("%d",&a[i][j]);

for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
{
if(num[i-1][j]>num[i-1][j-1])
num[i][j]=num[i-1][j]+a[i][j];
else
num[i][j]=num[i-1][j-1]+a[i][j];

}

max=0;
for(i=1;i<=n;i++)
if(num[5][i]>max)
max=num[5][i];
printf("%d\n",max);


getchar();
getchar();
return 0;
}
...全文
58 2 打赏 收藏 转发到动态 举报
写回复
用AI写文章
2 条回复
切换为时间正序
请发表友善的回复…
发表回复
heartzhizi 2013-04-30
  • 打赏
  • 举报
回复
额,汗颜啊,,居然这么错了,谢谢你了哈
FancyMouse 2013-04-30
  • 打赏
  • 举报
回复
if(num[5][i]>max) max=num[5][i]; => if(num[n][i]>max) max=num[n][i];

69,371

社区成员

发帖
与我相关
我的任务
社区描述
C语言相关问题讨论
社区管理员
  • C语言
  • 花神庙码农
  • 架构师李肯
加入社区
  • 近7日
  • 近30日
  • 至今
社区公告
暂无公告

试试用AI创作助手写篇文章吧