IE7下ckeditor4.1.2报错,无法显示,求解决

cdwy 2013-05-11 11:55:03
使用ckeditor4.1.2作为网页的编辑器,在IE8及以上版本浏览器都没有问题,但是当使用IE7访问的时候,页面报告js错误,ckeditor4不显示。
IE7错误信息如下:
用户代理: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.2; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.3; .NET

CLR 3.0.4506.2152; .NET CLR 3.5.30729; .NET4.0C; CIBA)
时间戳: Sat, 11 May 2013 15:40:39 UTC


消息: 'lang.contextmenu.options' 为空或不是对象
行: 615
字符: 612
代码: 0
URI: http://127.0.0.1:8080/lvhu/editor/ckeditor/ckeditor.js


将lang.contextmenu.options在工程中搜索,结果这一句却是在ckeditor.js中,看来是ckeditor对E7的兼容性问题,求指点解决之道。
...全文
197 点赞 收藏 7
写回复
7 条回复
wangzhione 2013年07月15日
CKEditor4.1.2与IE11也不兼容,报语法错误
回复 点赞
scscms太阳光 2013年05月14日
官网显示不是最新才ckeditor4.1.1吗
回复 点赞
等不到的彼岸花 2013年05月14日
下载一个新的,ckeditor4.1.1, 再说浏览器,现在ie11 都出来了,现在测试一般都是ie8的,之前的版本可以忽略不计了
回复 点赞
德仔 2013年05月13日
关注中。碰到同样问题
回复 点赞
cdwy 2013年05月13日
没有答案,自己顶一下
回复 点赞
装逼之王 2013年05月12日
换国产的kindeditor或者百度的
回复 点赞
网络科技 2013年05月12日
没必要用这么高的版本,用3.6的,就挺好的 如果非要用4。1版的话,那跟踪下js代码,看是那句不兼容,改下即可。 或者你等官方更新版吧,这个兼容性主要还是应该官方的来处理的。
回复 点赞
发动态
发帖子
JavaScript
创建于2007-09-28

5.1w+

社区成员

22.3w+

社区内容

Web 开发 JavaScript
社区公告
暂无公告