如何下载Eclipse3.7.1多语言包

xzou 2013-08-26 03:37:36
我们开发程序需要支持Wizard和Dialog上按钮多语言化,查了相关资料http://hi.baidu.com/sonmeika/item/4cf232865d468bccef083d16需要下载Eclipse多语言包,但是只能看见Eclipse 3.2.1的包,找不到3.7.1对应的包,请问谁知道3.7.1对应得多语言包从哪里下?下完以后在工程里面怎么设置可以实现Wizard和Dialog按钮的多语言化?是否只需要拷贝 org.eclipse.jface.nl1_XXXX.jar
org.eclipse.jface.text.nl1_XXXX.jar这两个包到pluins目录就够了,其他的包不需要复制过去?谢谢!
...全文
88 1 收藏 6
写回复
6 条回复
wufei151 2013年08月29日
给软件添加国际化功能就可以了。 添加完之后, 你可以在eclipse工具栏 RunConfiguration中设置启动参数。, 想用中文环境运行,就设置图中那个为zh就行了,你如果把字符串国际化了,那么你软件出来的界面就会是中文的,其他的语言也是一样,德文就改成de
回复 点赞
xzou 2013年08月28日
谢谢回答。我主要并不是想让Eclipse多语言化,关键是下完文件后后如何使用或者加入自己的工程,才能让我开发的软件具备多语言功能,比如调用MessageDialog,弹出的菜单具备根据操作系统的locale实现相应语言文字的多语言支持,包括菜单等,也就是如何利用Jface的语言包使我们自己开发出来的软件具备多语言的支持。
回复 点赞
我只是来偷代码的 2013年08月28日
我感觉楼主说的很好 但是.....
回复 点赞
xzou 2013年08月27日
有人知道吗?
回复 点赞
异常异长 2013年08月27日
http://ishare.iask.sina.com.cn/f/25498693.html

把三个文件夹复制到../eclipse/dropins里即可!如G:\Java\eclipse-SDK-3.7.1-win32\eclipse\dropins
回复 点赞
发动态
发帖子
Eclipse
创建于2007-09-28

3.1w+

社区成员

4.9w+

社区内容

Java Eclipse
社区公告
暂无公告