2.3与4.0差别

经常在黑云中出没 2013-09-03 10:24:45
这里聊聊SDK2.3与4.0的差别,大家不要给个链接列出一长串说明,主要讲讲自己开发过程中,哪些API是2.3不支持的。我先说说:
2.3中js调用java是有bug的,会崩溃。
2.3中不能播放网络音乐
2.3没有温度传感器
...全文
78 点赞 收藏 5
写回复
5 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
yuleyouxi 2013-09-03
产品硬件配置不高的话用4.0以上的体验不好。。。
回复
大家踊跃聊聊啊,我这边需要写份文档来决定我们产品的定位
回复
rouzi1230 2013-09-03
啊我也想知道 目前我遇到2.3不支持的,是之前做一个滑动动画效果,用animate中的transaX(Y)的方法都不支持~~~~~~~~~不知道其它怎么样~~~
回复
荒颜 2013-09-03
嗯 我也说下吧 1. 2.3通知中PendingIntent不能为空 比如你用通知展示下载 是不需要PendingIntent的 但是不设置的会报错 4.0就可以为空了 另外,4.0还有Notification.Builder 2.3没有 并且 4.0的Builder是getNotification()获取创建的Notification 而4.1是build() 2. 广播权限 4.0应用不启动是监听不到任何广播的
回复
go on ~~
回复
相关推荐
发帖
Android
创建于2009-10-09

7.8w+

社区成员

移动平台 Android
申请成为版主
帖子事件
创建了帖子
2013-09-03 10:24
社区公告
暂无公告