突然发现一个怪事:我的myeclipse8.6,修改myeclipse.ini中的内存系数居然无效!

网络科技 2014-03-30 07:29:47
myeclipse.ini内容如下:

-startup
AppData/Local/Genuitec/Common/plugins/org.eclipse.equinox.launcher_1.0.201.R35x_v20090715.jar
--launcher.library
AppData/Local/Genuitec/Common/plugins/org.eclipse.equinox.launcher.win32.win32.x86_1.0.200.v20090519
-install
E:/MyEclipse8.6
-vm
D:/Program Files/Java/jdk1.6.0_14/bin/javaw.exe
-configuration
configuration
-vmargs
-Xms512m
-Xmx1024m
-XX:PermSize=512m
-XX:MaxPermSize=512m
-XX:ReservedCodeCacheSize=100m

但用着用着,居然还是跳出了内存不足,里边提示的居然还是默认值!
即:
-Xms256m
-XX:MaxPermSize=512m
-XX:ReservedCodeCacheSize=64m
那个提示我关掉了,总之就是不起作用,
我网上看了下,有的说,可以在myeclipse.exe目前中,添加这些参数,但我试了,也没效果,这到底是怎么回事呢?

注:我的内存为4G,我的系统是64版的,myeclipse是32的吧,不知道跟这个有关系?
还有,我这个myeclipse是安装版的,非绿色版,是不是我当初安装时,配置参数被写到系统那里去了,所以我在这里,怎么改都没效果了?
虽然大部分时间不会跳出那个内存不足的提示,但偶尔跳出还是不爽,请高人指点解决之类。(最好别叫我再去安装一个什么的,因为,这个版本,我已做了不少优化之类的,再装显然麻烦啊)
...全文
1677 点赞 收藏 17
写回复
17 条回复
qq_34823833 2016年06月24日
引用 14 楼 xzy88 的回复:
结了,问题应该算是解决了,感谢各位参与
楼主 你最后是怎么解决的呢? 我也出现了这种情况
回复 点赞
坠落尘埃 2015年08月31日
学习了,好几天了,终于解决了,好开心啊
回复 点赞
huangkaifa 2014年10月20日
找这问题的时候发现原来我就是设了512,楼上的对话让我知道了一种新的可能,谢谢各位啦。 我也分享个链接吧 http://wenku.baidu.com/link?url=_nBWmEE6XpuVt7tIC7buTX6HqhSXXUq5gAJy5Yyp9e3xiyQa3drl4g-JPKkkHB881mnurdYE-7ABaxg5re2hCJaLryBWmzcOdKvwQCP5OLS
回复 点赞
Jason-Zai 2014年04月01日
首先,你可以用Windows->Preferences->General ,勾选 Show heap status.会在右下角弹出一个垃圾箱的图标,会显示当前的内存使用情况,请确认当前最大内存是否是512m. 如果是,说明你的设置可能没起作用,还有一种可能,你是否使用快捷方式启动的,如果是,建议去eclipse安装路径下执行exe文件,我以前碰到个类似用快捷方式不起作用,但是去安装目录使用就可以用。 希望对你有帮助,谢谢。
回复 点赞
网络科技 2014年04月01日
引用 9 楼 u014371430 的回复:
[quote=引用 8 楼 xzy88 的回复:] [quote=引用 6 楼 u014371430 的回复:] MyEclipse有个自动检查更新,你肯定关了. 虽然你修改了配置文件, 但myeclipse没有去检索 所以还是默认的. 分拿来
那个自动更新,确实我关闭了,但我现在开启了,还是会跳出那个提示窗啊,看来,还应该有别的原因才是啊[/quote] 你把myeclipse.ini拷贝到别的目录,然后在myeclipse下删掉它, 看看能不能启动,能启动说明myeclipse没调到它[/quote] 我把它删除了,就启动不了,应该是调到它了吧
回复 点赞
世人皆愚 2014年04月01日
引用 8 楼 xzy88 的回复:
[quote=引用 6 楼 u014371430 的回复:] MyEclipse有个自动检查更新,你肯定关了. 虽然你修改了配置文件, 但myeclipse没有去检索 所以还是默认的. 分拿来
那个自动更新,确实我关闭了,但我现在开启了,还是会跳出那个提示窗啊,看来,还应该有别的原因才是啊[/quote] 你把myeclipse.ini拷贝到别的目录,然后在myeclipse下删掉它, 看看能不能启动,能启动说明myeclipse没调到它
回复 点赞
网络科技 2014年04月01日
结了,问题应该算是解决了,感谢各位参与
回复 点赞
网络科技 2014年04月01日
引用 11 楼 u010015186 的回复:
首先,你可以用Windows->Preferences->General ,勾选 Show heap status.会在右下角弹出一个垃圾箱的图标,会显示当前的内存使用情况,请确认当前最大内存是否是512m.

如果是,说明你的设置可能没起作用,还有一种可能,你是否使用快捷方式启动的,如果是,建议去eclipse安装路径下执行exe文件,我以前碰到个类似用快捷方式不起作用,但是去安装目录使用就可以用。

希望对你有帮助,谢谢。

还真被你说中了,我确实是用快捷方式打开的,那个是我发送的桌面去的快捷方式。
按你的说了,我看了下,显示为:
851M of 1016M
我当前的配置为:
-configuration
configuration
-vmargs
-Xms256m
-Xmx1024m
-XX:PermSize=512m
-XX:MaxPermSize=512m
-XX:ReservedCodeCacheSize=100m

这样看来,我现在应该算正常了吧?
回复 点赞
兔子托尼啊 2014年04月01日
来学习的。。
回复 点赞
世人皆愚 2014年03月31日
MyEclipse有个自动检查更新,你肯定关了. 虽然你修改了配置文件, 但myeclipse没有去检索 所以还是默认的. 分拿来
回复 点赞
网络科技 2014年03月31日
引用 6 楼 u014371430 的回复:
MyEclipse有个自动检查更新,你肯定关了. 虽然你修改了配置文件, 但myeclipse没有去检索 所以还是默认的. 分拿来
那个自动更新,确实我关闭了,但我现在开启了,还是会跳出那个提示窗啊,看来,还应该有别的原因才是啊
回复 点赞
爱跳舞的铅笔头 2014年03月31日
引用 6 楼 u014371430 的回复:
MyEclipse有个自动检查更新,你肯定关了. 虽然你修改了配置文件, 但myeclipse没有去检索 所以还是默认的. 分拿来
分析的有道理。
回复 点赞
网络科技 2014年03月30日
回复 点赞
网络科技 2014年03月30日
应该是MyEclipse吧。。。 现在要不弹出那个提示窗了,等下弹出后,我把图放上去。。。
回复 点赞
ohfiner 2014年03月30日
你这是哪里内存不够,不会是JVM吧,或者tomcat?确定是MyEclipse?
回复 点赞
网络科技 2014年03月30日
引用 1 楼 huxiweng 的回复:
重启MyEclipse了吗
那肯定改完就重启了啊,甚至还重启了操作系统,还是没效果。。。
回复 点赞
ohfiner 2014年03月30日
重启MyEclipse了吗
回复 点赞
发动态
发帖子
Eclipse
创建于2007-09-28

3.1w+

社区成员

4.9w+

社区内容

Java Eclipse
社区公告
暂无公告