Informatica powercenter 服务中断问题,请大侠帮忙解答,谢谢!

cnhnlyp 2014-07-22 11:14:31
以下是日志中取出的一段信息: 请大侠解释详细点产生该问题原因是什么,然后怎么解决避免这种问题,谢谢!
2014-07-21 18:38:24,821 ERROR [Domain Monitor] [DOM_10095] The master gateway data in the domain configuration repository was updated during the last refresh
time interval 98556.
2014-07-21 18:38:24,822 FATAL [Domain Monitor] [DOM_10094] Cannot update the data for the master gateway node [node01_CECIFETL01] within the refresh interval
time [96000]. The node will not continue as a master gateway node. Verify that the connection to the domain configuration repository database is valid.
2014-07-21 18:41:29,673 INFO [Master Elect Data Writer] [DOM_10161] Stopped the writer thread for the master gateway node election. Deleting the data from t
he domain configuration repository.
2014-07-21 18:41:29,711 INFO [Master Elect Data Writer] [DOM_10146] Obtained the row level lock on the ISP_MASTER_ELECT_LOCK table.
2014-07-21 18:41:29,714 INFO [Master Elect Data Writer] [DOM_10147] Deleting the row for node [node01_CECIFETL01] in the domain configuration repository.
2014-07-21 18:41:29,715 INFO [Master Elect Data Writer] [DOM_10147] Deleting the row for node [node01_CECIFETL01] in the domain configuration repository.
2014-07-21 18:41:29,721 INFO [Master Elect Data Writer] [DOM_10151] Released row level lock on the ISP_MASTER_ELECT_LOCK table.
...全文
4792 点赞 收藏 3
写回复
3 条回复
切换为时间正序
当前发帖距今超过3年,不再开放新的回复
发表回复
orionlew 2015-10-30
应该是主机和备机之间的交互问题,可以单独用一台机器试试看
回复
bigteddy 2015-04-09
May be network issue. Workaround The MasterDBRefreshInterval custom parameter can be set for the Domain to increase the refresh interval and avoid temporary issues. Note If there is an on going issue with connectivity this parameter will not resolve this issue. The underlying issue must be resolved in order to avoid this in the future. You can set the MasterDBRefreshInterval custom parameter as follows: (For complete analysis it's required to have TCP Dump and Spy log analysis) Login to the Administration Console Click on the Domain on the Left-Hand navigation On the Right-Hand Navigation click on Properties Scroll to the bottom of the Properties page and edit the Custom Properties Under Properties , go to Custom Properties > Edit Specify the parameter name MasterDBRefreshInterval and the value in seconds (30 or lesser is recommended). Example MasterDBRefreshInterval=30 Click OK. Restart the domain. This value will increase the refresh interval to 30 seconds. The default value is 8 seconds. You can set the domain property from the infacmd.sh command line utility: $INFA_HOME/isp/bin/infacmd.sh -dn DomainName -un Administrator -pd Administrator -do MasterDBRefreshInterval=X where X is a numeric valus in seconds.
回复
s7197196 2015-02-14
我也遇见过这样的问题,也没有彻底解决,每次都是重新启服务
回复
相关推荐
发帖
Informatica
创建于2013-03-06

229

社区成员

讨论 Informatica 数据集成相关技术、数据隐私保护相关技术
申请成为版主
帖子事件
创建了帖子
2014-07-22 11:14
社区公告
暂无公告